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EthoVision XT sample experiments

experiments available
 Morris water maze XT160 (see the EthoVision XT installation USB stick)

For this experiment, see the document Description of Morris water maze sample 
experiment - EthoVision XT 16.pdf, which you can find on the EthoVision XT installation 
USB stick and the EthoVision XT download page.

 Open Field test XT160 page 5

 Elevated plus maze XT160 10

 Novel Object Recognition test XT160 16

 Novel Object Recognition test XT160 20

 Porsolt forced swim test XT160 25

 Social Interaction test XT160 28

 Social approach test XT160 33

 PhenoTyper hardware XT160 37

 DanioVision with 96 wells XT160 43

 DanioVision with camera zoomed into four wells XT160 49

 Barnes Maze XT160 54

 Mouse Behavior Recognition in Open Field XT160 60

 Mouse Behavior Recognition in Social Discrimination XT160 65

 Rat Behavior Recognition in PhenoTyper XT160 71

 Subject Counter with JavaScript XT160 77

note  Not all experiments may be available at the time you download this document. Check 
our web site regularly for more sample experiments.

For more information

The Application Manual - EthoVision XT 16 contains useful information on many of the tests 
listed above. To open this manual, choose Apps > Noldus > EthoVision XT 16 Other 
Documentation. You can also find this manual on the EthoVision XT installation USB stick.
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how to use the sample experiments
To open the sample experiments you must open the backup files:

1. Choose File > Restore Backup, or in the EthoVision Startup window, choose Restore 
sample experiment.

2. Browse to the backup file that you want to restore and click Open.

3. Browse to the default experiment location. This may be:
 If you purchased a PC with EthoVision XT:

D:\Noldus\EthoVision XT\Experiments.
 In other cases

C:\Users\Public\Documents\Noldus\EthoVision XT\Experiments.

4. Click OK to restore the experiment in this location.

Notes

 If opening from the installation DVD does not work, copy the backup file to your 
computer first. 

 You can find the associated media files in the Media Files subfolder of the experiment’s 
folder. The sample experiment Open field XT160 has an associated external data file 
which is stored in the External subfolder of the experiment's folder.

 For two sample experiments, Social approach test XT160 and Novel Object Recognition 
test XT160, you may not be able to acquire additional trials. These two experiments are 
based on Deep learning and if the driver software of the GPU (graphics card) of your 
computer is not compatible with the CUDA version needed to use Deep learning, data 
acquisition is not enabled. However, you can explore the data already acquired. Another 
option is to install those experiments on a PC with a more recent GPU driver software.
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Open Field test XT160

overview
The Open field test is an experimental test used to assay general locomotor activity levels, 
anxiety, and willingness to explore in rodents. In this experiment, EthoVision XT is set to 
track the nose, center and tail-base points of mice of different colors: in Trial 1, a dark (C57BL/
6J) mouse; in Trial 2, a white (ICR) mouse.

Media Files

Dark mouse.mpg, White mouse.mpg.

arena settings
In the Arena Settings, the open field is divided into two zones, Center and Border. Rodents 
typically prefer to spend time in enclosed spaces and will therefore tend to spend more time 
in the Border (safe zone) versus the Center (less safe zone).

An additional zone is defined for the Wall of the open field. You can use this zone to 
estimate:

 Thigmotaxis, when the mouse’s center point is at short distance from the walls. For this 
purpose, use the Analysis profile Distance from Wall zone.

 Sniffing/Rearing at the walls, when the mouse’s nose is detected within the Wall zone. 
For this purpose, use the Analysis profile Nose over Wall zone.

trial control settings
The Trial Control Settings Trial Control Settings 1 has been defined so that tracking starts 
after the mouse has been detected for 1 s in the arena, and lasts until the end of the video 
file.

detection settings
The experiment contains two Detection Settings profiles:

 Dark mouse. Uses Dynamic subtraction as a method for finding the mouse of a white 
background. Use this profile to track from the video file Dark mouse.
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 White mouse. This Detection Settings profiles uses Differencing as a method to find the 
mouse. The reason is that other detection methods would not be able to find the 
mouse’s head when the animal rears at the wall, because of the low level of contrast 
with the white wall. However, Differencing can pick very subtle changes in the image 
and in most cases can find the whole contour of the mouse.

data profiles
Choose Analysis > Data Profile > Open. The experiment has three Data profiles:

 All data. This is a default Data profile to analyze all tracks together, without any filtering 
or nesting criteria.

 With time bins. Data are split in one-minute time bins. Use this Data profile to view 
temporal changes in the behavior of the subject.

 Groups. This Data profile is an example of how you can group tracks, for example to all 
trials with the dark mouse vs. all trials with the white mouse. Use this Data profile when 
you track multiple times from the same video file. Start tracking at different times of the 
video to create some within-group variation in the results.

analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment has three Data profiles:

 Distance and velocity. This profile contains variables to quantify locomotor behavior, for 
example to calculate the mean velocity and the total distance moved of the animal's 
center-point.

 JS body length. This is an example of a custom variable created with JavaScript code. It 
uses EthoVision XT raw data to calculate the length of the mouse (from nose to tail-base) 
at each sample time. Plot this variable with Integrated Visualization to see how this 
variable varies with behavior (walking vs. sitting/grooming, etc.).
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With JavaScript custom variables, you can extract a wealth of additional information on 
the behavior of your subjects. For more details, see the EthoVision XT Help.

 Crossings. This profile contains a variable of type In zone that measures how often the 
mouse crosses the center of the open field.

 Distance from walls. This profile contains a variable of type Distance to zone for 
calculating the average distance of the mouse to the walls.

 Nose over Wall zone. This profile contains a variable of type In zone, which measures the 
time that the mouse’s nose is within the wall zone. This variable estimates the time that 
the subject rears at the walls.

tip  With the Mouse/Rat Behavior Recognition module you can detect rearing behavior 
automatically.

trial statistics
Choose Analysis > Results > Statistics and Charts. 

Select other Data profiles and Analysis profiles from the lists on the toolbar to view more 
results.

group statistics and charts
Choose Results > Statistics and Charts, then click the Group Statistics and Charts tab. Select 
the Data profile Groups from the list on the toolbar. 

tip  Acquire more trials using the two video files and the corresponding detection settings. 
Start tracking at various points in the video to create some variation in the groups. Then 
open the Group Statistics and Charts.
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integrated visualization
Choose Results > Integrated Visualization, then choose the Data profile and the analysis 
profile from the lists on the toolbar to select the variables you want to plot.

Choose Distance and velocity from the Analysis profile list on the toolbar. 

Next, on the Track Plot Settings pane click the Colors tab. Under Level choose Sample and 
then Velocity (Center point) as the Variable to visualize. When you play the tracks, you see 
the data points in different colors based on the mouse’s speed.

tip  Click the Jump to end button to view the entire tracks. 
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heatmap visualization
Choose Results > Heatmap Visualization. Select the Data profile With time bins from the list 
on the toolbar, then click the Time bins button on the right under Layout presets. 

There you see where the mouse spent time in each of the one-minute time bins.

tip  Click the Fit all button on the toolbar to view all time bins in one row.

acknowledgments
Video files were kindly provided by Dr. Lior Bikovski, director of the Myers Neuro-Behavioral 
Core Facility, Sackler School of Medicine, Tel Aviv University, Tel-Aviv, Israel; and School of 
Behavioral Sciences, Netanya academic college, Netanya, Israel.
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Elevated plus maze XT160

overview
This is an example of a plus maze experiment with a mouse. We used nose-tail tracking to 
calculate the mouse’s head dips over the edge of the open arms of the maze. 

Media file

Elevated plus maze mouse.avi

arena settings

Arena Settings 1

The North and South arms of the maze are open, the other two (West and East) are closed. 
The North and South arms are defined as the cumulative group Open arms in the Arena 
Settings. The West and East arms are defined as the cumulative group Closed arms. We used 
nose-tail tracking to investigate how much time the mouse spent in the open arms. We also 
defined the zones Outside North open arm and Outside South open arm, which together 
form the cumulative zone Outside open arms. We used this cumulative zone to investigate 
how often the mouse showed head dips over the edge of the open arms. 

trial control settings

Trial Control Settings 1

In the Trial Control Settings we defined a condition to start the track two seconds after the 
mouse was first detected in the arena. 

detection settings

Detection Settings 1

Dynamic subtraction is the detection method used. A maximum body size of 1300 pixels is 
used. This is to prevent EthoVision from tracking the arm of the experimenter who puts the 
animal in the arena. To prevent EthoVision from tracking noise, a minimum body size of 100 
pixels is used. Contour dilation is used to compensate for low contrast in some parts of the 
arena, which makes the rodent’s shape less consistent.
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track smoothing profiles
The experiment has two Track Smoothing profiles:

 Smoothing off. Track smoothing is not enabled.

 Minimal Distance Moved on. Minimal Distance Moved is selected. Keep this profile active 
especially when calculating distance moved, since it filters out false movements caused 
by noise when the mouse is sitting still.

data profiles
Choose Analysis > Data Profile > Open. The experiment has three Data profiles:

 All data. The default Data profile without any filtering or nesting criteria.

 Results in 30-s bins. This is a Data profile that splits the tracks in 30-s intervals called 
bins. Note that the last bit of the track is excluded from analysis because it is shorter 
than 30 s.

 Results in open/closed arms - With results per zone, and the center point of the mouse 
and the zones open arms and closed arms selected. This divides the tracks into segments 
in which the center point of the mouse is in either the open arms or the closed arms. 

analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment has four Analysis profiles:

 Velocity and distance moved. To calculate the (mean) velocity and (total) distance moved 
of the animal's center-point.

 Time in open/closed arms. Contains the following variables:
  In Zone. To calculate the total time spent in open arms and closed arms separately, 

also as percentage of the total recording time. For frequency of arm entries, see the 
Analysis profile Arm entries below.

 When in open arms > 5 s. This variable is an example of how you can mark events 
based on the duration of a behavior. Here, we want to find the number of times that 
the animal spent more than a specific time, 5 seconds, in either of the open arms. 
To determine the instances of zone visits that last longer than a specific time, a Free 
Interval is used based on the dependent variable In Zone. The start condition is 
defined as the moment the animal’s center-point is in one of the open arms for more 
than 5 s. The stop condition was defined as the moment the animal’s center-point 
was no longer in the open arm.
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Double-click this variable to see how it was defined. For more information, see Free 
intervals in the EthoVision XT Help.
When you plot this variable in the Integrated Visualization (Analyze > Results > Plot 
Integrated data), you see that only the visits to the open arms that lasted longer than 
5 second are plotted.

Note that the interval starts five seconds (or the time specified in the start condition 
of the Free Interval Settings) after the animal actually enters the zone. 

 Nose over edge open arms. To calculate the frequency and the duration of head dips over 
the edges of the open arms. To do so, the number of times and the duration the nose 
point was present in the cumulative zone Outside open arms was assessed.

 Arm entries. This profile contains two Zone transition variables. Entries to Open arms 
counts the transitions from the Center zone to either open arm. Entries to Closed arms 
counts the transitions from the Center zone to either closed arm. Zone transitions are 
generally more reliable indicators of true zone entries than In zone variables, especially 
when the body points jitter around the zone borders.

 Body Length with JavaScript. This profile contains a custom variable written with 
JavaScript code. You can use JavaScript to extract more information from the track data. 
In this example, the JavaScript code defines the body length as the sum of the distance 
between the nose and the center and between the center and the tail base point of the 
mouse. For more examples of variables with JavaScript, see JavaScript custom variables 
under Drivers and tools/Utilities on the EthoVision XT installation USB stick.

trial statistics
Choose Analysis > Results > Statistics and Charts. 

Choose the Analysis Profile and Data Profile from the lists on the toolbar. With the following 
combination, you calculate the time that the subject spent in the open arms and in the 
closed arms. This time is expressed in seconds and in percentage of the total time.
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Combine the Data profile Results in open/closed arms with the Analysis profile Velocity and 
distance moved. There you have the velocity and distance moved in the open and closed 
arms. The subjects animal moved longer in the closed arms in comparison with the open 
arms. The velocity in the open arms was slightly lower than in the closed arms.

Combine the Data profile All Data with the Analysis profile Arm entries. There you compare 
the number of entries between open arms and closed arms.

heatmaps
Choose Analysis > Results > Plot Heatmaps.

Choose the Data profile Results in 30-s bins from the list at the top. Next, click the Time bins 
button on the right-hand pane. You see that the mouse enters the open arms only in the last 
two time bins. This indicates that the mouse needs time to start exploring.

tip  Click the Fit all button on the toolbar to view all time bins in one row.
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integrated visualization
Choose Analysis > Results > Plot Integrated data. Choose the Analysis Profile and Data Profile 
from the lists on the toolbar.

Head dipping

Choose the Analysis Profile Nose over edge open arms to display the head dips in a plot. 
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Body length

Choose the Data profile All data with the Analysis profile Body Length with JavaScript to plot 
the body length against time. There you see an increase in body length at the end of the 
video, each time the mouse enters the open arms.

acknowledgment
The video was provided by Niek van Stipdonk from Delta Phenomics BV, who is 
acknowledged.
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Novel Object Recognition test XT160

overview
This is an example of a novel object test in which a mouse is confronted with two objects, a 
familiar object (on the right) and a novel object (on the left). 

 We use nose-tail tracking to calculate the latency and frequency of investigating each of 
the objects.

 In the Trial Control Settings, we can control the duration of tracking based on the 
exploration behavior of the subject.

Media file

Novel object test.mp4

arena settings
Zone Group Objects contains two zones covering the two objects. In Zone Group Quadrants 
the arena is divided into four quadrants (northwest, northeast, southwest and southeast), 
Zone Group 2 cm around objects contains additional zones. These zones are used to calculate 
the dependent variable Head directed to zone.

 To make an exact copy of the arena and its zones, and edit that copy, right-click Arena 
Settings 1 and select Duplicate.

 To create an arena from scratch, choose Setup > Arena Settings > New, load the video and 
make sure to adjust the video aspect ratio. To do so, click the Adjust Aspect Ratio button 
at the bottom of the Arena Settings window.

In the window that appears, select Custom and enter 352 x 288.

trial control settings
Choose Setup > Trial Control Settings > Opens. The experiment contains two items:
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 Stop at end of video. If you use this settings profile to acquire the track, tracking stops at 
the end of the video file.

 Stop when exploration > 5 s. It is often required to have a constant amount of exploration 
in the data to control for inter-individual variation. This settings profile contain a 
condition that waits until the cumulative time that the nose of the mouse is inside the 
interest zone exceeds five seconds. The interest zone is given by the sum of the “Novel 
object” zone plus an outer zone (Novel object + 2 cm). Tracking stops when the condition 
is met. This results in tracks that all contain five seconds of exploration.

data profiles
 Choose Analysis > Data Profile > Open. The experiment contains three Data profiles:

 All data. The default Data profile without any filtering or nesting criteria.

 From track start till novel object exploration. This Data profile selects the time from the 
track start to when the mouse starts exploring the object. This is defined when the 
mouse’s nose is either in the zone “novel object” or “novel object + 2cm” for one second 
without interruptions. For this purpose, the Free interval definition uses the variable In 
zone with the statistic Current duration. Use this Data profile in combination with the 
analysis profile Total distance moved to calculate the total length of the track in this 
interval.

 From track start till exploration reaches 5 s. This Data profile selects the time from the 
track starts up to when the mouse has explored the object for a total of five seconds. Like 
in the previous Data profile, exploration is defined when the mouse’s nose is either in 
the zone “novel object” or “novel object + 2 cm”. The difference is that the Free interval 
uses the variable In zone with the statistic Cumulative duration, not Current duration, to 
calculate when the mouse explores the object for a total time of five seconds. Use this 
Data profile in combination with the analysis profile Total distance moved to calculate 
the total length of the track in this interval. 

analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment has four analysis profiles.

 Exploration of objects. It contains two variables, one of type In zone and one of type 
Distance to zone. Use In zone to calculate the time spent exploring each of the objects, 
and Distance to zone to calculate the average distance between the animal’s center 
point and each object.
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 Visits to the four quadrants. It contains the variable In zone, to calculate the time spent, 
the percentage time spent, the time until the first visit and the number of visits for each 
of the four quadrants.

 Head pointing to objects. Exploration is normally defined as directly attending to the 
object when the head is within a 2 cm radius of the object. The dependent variable Head 
directed to zone is especially designed to calculate this. Two variables are included in this 
profile:
 Head directed to Novel object
 Head directed to Familiar object

Both variables are instances of Head directed to zone. To see the difference between the 
two, double-click one of the variables’ name. Under Zone of interest, a zone is selected 
(either Novel object or Familiar object). Next to Calculate when, it is specified that the 
mouse’s nose point be around the interest zone (object + 2 cm; this zone is defined in the 
Zone group 2 cm around objects). The value of Head directed to the zone is calculated 
only when this condition is met.

 Total distance moved. Contains the variable Distance moved of the center point. Use this 
in combination with the Data Profile From track start till novel object exploration to 
calculate the total length of this track segment.

trial statistics
Choose Analysis > Results > Statistics and Charts. Select the Data Profile and Analysis Profile 
from the lists on the toolbar.

Analysis of exploration

Choose Data profile All data and the Analysis profile Exploration of objects. The mouse 
visited the novel object more often than the familiar object (locate the Frequency column for 
those zones). The difference between Trial 1 and 2 is that Trial 2 ended earlier, when the 
exploration of the novel object reached five seconds.
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Choose Data profile All data and the Analysis profile Head pointing to objects. This variable 
measures the time that the mouse displayed interest in an object. Compare the total 
duration of Head directed to zone between the novel object and the familiar object. 

Analyzing part of the tracks

When you select one of the other Data profiles, From track start till novel object exploration 
and From track start till exploration reaches 5 s, you analyze a segment of the track instead 
of the entire track. For example, when you select the Analysis profile Total distance moved, 
you can calculate how long the mouse moved until the first exploration event or after the 5-
second exploration bout, respectively. 

integrated visualization
Choose Analysis > Results > Plot Integrated Data. Select the Data Profile and Analysis Profile 
from the lists on the toolbar.

When you use the Data Profile All data with the Analysis profile Exploration of objects or 
Head pointing to objects, you can visualize the instances of exploration plotted against time.

tip  To visualize more zones over the video, choose Show/Hide > Arena Features in the upper 
right corner of the screen. 

acknowledgment
Video file by courtesy of Dr. Liang Zhang, Toronto Western Hospital, University of Toronto, 
Toronto, Canada.
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Novel Object Recognition test XT160

overview
In the Novel Object Recognition (NOR) test, the researcher evaluates the recognition memory 
of the animal. A mouse is presented with two similar objects during the a session 
(Familiarization), and then one of the two objects is replaced by a new object during a 
following session (Test). The amount of time taken to explore the new object provides an 
index of recognition memory.

In this sample experiment, the software tracks the mouse’s nose to quantify its exploratory 
behavior. Three trials have been acquired:

 Trial 1 (Habituation). The mouse is free to explore the open field for 5 minutes.

 Trial 2 (Familiarization). The mouse explores two identical objects, Object 1 and Object 2.

 Trial 3 (Test). The mouse explores one familiar object, the same as Object 2, and one novel 
object, which replaced Object 1.

note  This experiment uses the Deep learning method for tracking the subject’s nose point. 
This method requires recent CUDA software and a powerful GPU card. These requirements 
may not be met in some computers. However, you can still visualize the data but you cannot 
acquire new data.

Media files

 NOR test video no objects.mpg

 NOR test video two identical objects.mpg.

 NOR test video familiar and novel object.mpg

Reference

Leger et al. (2013). Object recognition test in mice. Nature Protocols 8: 2531–2537.

experiment settings
Choose Setup > Experiment Settings.

To track the subject’s nose, under Tracked Features the option Center-point, nose-point and 
tail-base point detection is selected. 

Under Body Point Detection Technique you see that EthoVision XT uses Deep learning to find 
the body points of the mouse.
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arena settings
Three Arena Settings are defined:

 With no objects. Use this profile when tracking from the video file named NOR test video 
no objects.mpg.

 With identical objects. Use this profile when tracking from the video file NOR test video 
two identical objects.mpg.

 With novel object. Use this profile when tracking from the video file NOR test video 
familiar and novel object.mpg.

In the last two Arena Settings profiles, the zone group Objects contains zones covering the 
two objects and boundary zones around each object. The zones are slightly different in the 
two Arena Settings profiles because the objects slightly differ in size and position.

You can use the boundary zone to define the properties of the dependent variable Head 
directed to zone.

For all the Arena Settings profiles, two zones Floor and Wall are defined in a separate group 
Floor and Wall which you can use for additional analyses.

trial control settings
Choose Setup > Trial Control Settings > Open. The experiment contains two items:

 Trial Control Settings 1. This is the default settings profile to acquire the track.

 Start after 5 seconds. With this profile contains a condition that waits five seconds before 
starting data acquisition. You can use this profile to avoid faulty tracking at the 
beginning of the video when a change in the lighting occurs.
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detection settings
Choose Setup > Detection Settings > Open. The experiment contains three profiles, one for 
each video. The main difference between the three profiles lies in the background image 
(with or without objects). make sure that you use the correct profile before you start 
acquisition.

data profiles
Choose Analysis > Data Profile > Open. The experiment contains three profiles:

 All Data. This is the default Data profile.

 Contrast object exploration. This Data profile contains two result boxes. The aim of this 
profile is to compare exploration of the two objects when they are identical versus when 
one of them is novel. The two selections are based on the type of Arena Settings used.

 Time bins. You can use this profile to analyze exploration per time interval.

analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment contains two profiles:

 Exploration. Here a few variables have been defined to measure exploratory behavior.
 Nose within object zone measures the time that the subject’s nose touches each 

object.
 Distance to objects returns the distance of the subject’s nose to the objects.
 The variables of type Head directed to [object name] measures the time that the 

subject’s head is directed to the zone, while its center point is in the boundary zone. 
The results are similar to those obtained with Nose within object zone, however this 
adds the condition that the head is directed toward an object, even if the nose is not 
precisely inside the object zone. This should quantify the time that the mouse’s 
attention is directed toward the object.

 Locomotion. In this profile the variables Distance moved and Velocity are defined.

statistics
Choose Analysis > Results > Statistics and Charts.

 From the Data profile on the toolbar, choose All Data and from the Analysis profile list 
choose Exploration.
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Under Trial Statistics, the results are shown per trial. The table gives you the statistics per 
zone. Note that some zones give result “-” or zero; those results refer to zones that were 
not in the Arena Settings used to acquire that trial. For example, for trial 2, the zones 
Object 1 and Object 2 were used. For trial 3, the zones Familiar object and Novel object 
were used.

 From the Data profile on the toolbar, choose Contrast object exploration and from the 
Analysis profile list choose Exploration. Choose then Group Statistics and Charts.

The table shows two groups, one for the Familiarization phase where you compare 
Object 1 and Object 2. The second group is for the test phase where you compare Familiar 
object with Novel object. 

In this example we focus on the Cumulative Duration of the variable Nose within object 
zone.

Compare the statistics of exploration of Object 1, which was present in Trial 2 with that of 
Novel Object, which replaced Object 1 in Trial 3.
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integrated visualization
Choose Analysis > Results > Plot Integrated Data.

From the lists on the toolbar, select the Data profile, the Analysis profile and the trial number 
that you want to visualize.

heatmap visualization
Choose Analysis > Results > Plot Heatmaps.

From the lists on the toolbar, select the Data profile Contrast object exploration.

Heatmaps give you an immediate sense of where the animal spent most of the time during a 
trial. The following heatmap shows the position of the nose point in Trial 2 (Familiarization; 
left) and Trial 3 (Test; right). In the Test phase, the positions of the nose point are far more 
dense around the novel object than those at the same location during the familiarization 
phase (left).

acknowledgments
Video files were kindly provided by Dr. Lior Bikovski, director of the Myers Neuro-Behavioral 
Core Facility, Sackler School of Medicine, Tel Aviv University, Tel-Aviv, Israel; and School of 
Behavioral Sciences, Netanya academic college, Netanya, Israel.
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Porsolt forced swim test XT160

overview
This experiment shows a Porsolt forced swim test performed on two subjects, each being 
tracked in its own arena. Note that you need the Multiple Arenas Module to be able to track 
subjects in two arenas.

Media file

Porsolt Swim Test.mp4

arena settings
In the Arena Settings, an arena has been defined over each of the two water tanks in the 
video image. No zone has been defined as in this experiment the researcher was not 
interested in the location of the subject within the tank.

trial control settings
Two Trial Control Settings have been defined to stop tracking at different times, depending 
on which session the trial belongs to:

 Pretest. The ‘Time’ condition Stop - Pretest causes the trial to stop 15 minutes after the 
start of tracking.

 Test.The ‘Time’ condition Stop - Test causes the trial to stop 5 minutes after the start of 
tracking. These settings were used to acquire Trial 1.

detection settings
In the Detection Settings, the Static subtraction method has been chosen. These settings are 
used to acquire Trial 1. Dynamic subtraction 

trial list
In the Trial List, the variable Session has been defined, with two possible values, Test and 
Pretest. Each trial is assigned to either value. Trial 1, a Test, has been acquired with Animal ID 
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1 and 2. Other variables are Treatment, a variable with values Drug and Saline, Animal ID and 
Dose, a numerical variable with values 0, 2 and 5 mg/l. You can use those variables to filter 
data and group subjects.

Furthermore, two additional trials have been planned: Trial 2, a Pretest, and Trial 3, a Test, 
both with Animal IDs 3 and 4.

data profiles
Choose Analysis > Data Profile > Open. The experiment has two Data profiles.

 All Data. Contains all data in the experiment. Use this Data profile to visualize statistics 
calculated per trial.

 Drug vs. Saline. With two groups based on the independent variable Treatment. Use this 
Data profile to compare statistics and charts of the variables per group.

analysis profiles
Choose Analysis > Analysis Profile > Open. 

Two Analysis profiles include the Mobility dependent variables. Each profile contains two 
variables, Mobility continuous and Mobility state. Mobility continuous returns the value of 
body mobility based on the change in body area between subsequent samples. Mobility 
states marks the behavior of the subjects with one of three possible scores (Immobile, 
Mobile, Highly mobile) based on the value of Mobility relative to user-set thresholds. Double-
click the name of the variable to view those settings.

 Mobility_1. Mobility is calculated with an Averaging interval of 1, that is, the value is 
obtained directly from the per-sample change in the subject’s apparent body area. 
However, random changes in the body area around the thresholds, due for example to 
changes in the orientation of the animal independent of its swimming behavior, can 
influence the value of Mobility, resulting in many transitions between Mobility scores 
(e.g. Mobile > Highly mobile > Mobile > Highly mobile, etc.). For this reason we also 
defined a smoothed Mobility variable (see below).

 Mobility_10. The values of Mobility are smoothed out using an Averaging interval larger 
than 1. In this example, the interval is 10 samples wide. The effect of random changes in 
body area is minimized, and that results in fewer transitions between Mobility scores.

note  For all variables, the following thresholds were used: Immobile below 6.5%, Highly 
mobile above 22%. Feel free to edit those values and open the Integrated Visualization. The 
resulting Mobility scores should match the behavior of the rats in the video as much as 
possible.
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trial statistics
Choose Analysis > Results > Statistics & Charts.

To view the results, select the Data profile and Analysis profile from the list on the toolbar.

group statistics and charts
Choose Analysis > Results > Statistics & Charts and open the tab Group Statistics and Charts. 
Select the Data Profile and Analysis Profile from the lists on the toolbar.

Below you see one of the charts that appear when you select the Data profile Drug vs. Saline 
and the Analysis profile Mobility_10.

acknowledgment
The experiment was provided by Sanna Lemming Kjær, National Research Centre for the 
Working Environment, Copenhagen, Denmark.
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Social Interaction test XT160

overview
This is an example of how you can analyze the interaction between two or more animals in 
the same arena. Note that you need the Social Interaction Module to track more than one 
animal per arena.

Media file

Social Interaction test.mp4.

experiment settings
In the Experiment Settings, we set the Number of Subjects per Arena to 2 and the Tracked 
features to Center-point, nose-point and tail-base detection. The Subject roles are Control 
and Treated.

arena settings
In the Arena Settings, the Quadrants zone group includes four quadrants to be able to 
analyze the location of the subject during the test.

 To create a new Arena Settings profile with pre-defined arena and zones, right-click 
Arena Settings 1 and select Duplicate.

 Alternatively, to create an Arena Settings profile from scratch, using the same video file 
as background image, choose Setup > Arena Settings > New, and load the video file. Make 
sure to adjust the video aspect ratio. To do so, click the Adjust Aspect Ratio button at the 
bottom of the Arena Settings window.

In the window that appears, choose Custom and enter 768 and 576 as video image size. 
This adjusts the video image size to the original proportions.
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trial control settings
A Trial Control Settings profile One-minute track has been defined. Tracking starts when both 
subjects are detected in the cage for two seconds. With this Trial Control profile you ensure 
that the subjects are tracked for exactly the same time. The other condition placed 
immediately before “Stop track” ensures that tracking stops after one minute.

detection settings
In the Detection settings, we selected Dynamic subtraction with Marker-assisted 
identification.

When you select Center-point, nose-point and tail-base detection in the Experiment settings 
for multiple animals, EthoVision XT automatically selects the Rodents/For occlusions as 
nose-tail tracking method.

Because the animals frequently come in close contact, in the advanced Subject Size settings, 
the Modelling effort optimized for slider is moved to Modelling and the Shape stability 
optimized for slider is moved to Occlusions. For details about those options, see Advanced 
detection settings: Subject size (multiple animals per arena) in the EthoVision XT Help.

trial list
Choose Setup > Trial List. User-defined variables Dose, Day and Marker color are defined. You 
can use the Marker color variable to specify Subject role * Marker color combinations. In the 
acquired trial, the Treated subject has a yellow marker.

data profiles
Choose Analysis > Data Profile > Open. The experiment contains the default data profile with 
all data.

To analyze the behaviors of the animals in the four quadrants separately, click the Settings 
button on the Results box, select Results per zone and select the four quadrants. Then redo 
the analysis.

analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment contains the Analysis profile 
Social behavior with the following dependent variables:
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 Distance nose point to tail base Control. This calculates the mean distance from the 
nose-point of both animals to the tail-base of the Control animal.

In the statistics table, look up the value for the Treated animal, to obtain the distance 
from the nose point of the treated animal to the tail base of the control animal.

 Proximity nose point to tail base Control. This calculates the mean duration of the states 
In proximity and Not in proximity based on the distance from the nose-point of both 
animals to the tail-base of the Control animal. The states In proximity and Not in 
proximity have with a lower and upper threshold of 5 and 6 cm, respectively.

In the statistics table, look up the value for the Treated animal, to see whether the nose 
point of the treated animal is in proximity to the tail base of the control animal. 

 Distance nose point to tail base of Treated. This calculates the mean distance from the 
nose-point of both animals to the tail-base of the Treated animal.

In the statistics table, look up the value for the Control animal, to obtain the distance 
from the nose point of the control animal to the tail base of the treated animal. 

 Proximity nose point to tail base of Treated. This calculates the mean duration of the 
states In proximity and Not in proximity based on the distance from the nose-point of 
both animals to the tail-base of the Treated animal. The states In proximity and Not in 
proximity have with a lower and upper threshold of 5 and 6 cm, respectively.

In the statistics table, look up the value for the Control animal, to see whether the nose 
point of the control animal is in proximity to the tail base of the treated animal. 

 Body Contact. This calculates whether the animals are in contact with each other or not. 

trial statistics
Choose Analysis > Results > Statistics & Charts. 

For variables of distance and proximity to “Control”, locate the row for Treated. There you 
find the value of distance or proximity duration of Treated vs. Control. For example, the 
average distance from the nose point of Treated to the tail base of Control was 29 cm.
30  Social Interaction test XT160



Similarly, for the variables of distance and proximity from the control subject to the treated 
subject, locate the row for Control. The average distance of the nose of Control to the tail-
base of Treated was about 24 cm.

integrated visualization
Choose Analysis > Results > Plot integrated data. 

The figure below shows an example of the variable In proximity based on the nose-point of 
Treated and the tail-base of Control.
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Please note that the plots for the subject Control displaying Distance/Proximity of nose 
point to the tail base of Control, that is, the distance between body points of the same 
animal, do not contain useful information. The same counts for the plots of the subject 
Treated displaying Distance/Proximity nose point to the tail base of Treated.

The next figure shows the plot of the variable Body contact. Body contact is scored when the 
animals were in physical contact with any part of their bodies, not just their nose points or 
tail bases.

acknowledgment
Video was recorded with the help of Niek van Stipdonk and Raymond de Heer (Delta 
Phenomics, The Netherlands).
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Social approach test XT160

overview
This sample experiment uses a method based on trained neural networks (Deep learning) to 
track the nose of the test subject. In the Social approach test, the test subject is free to 
explore the apparatus divided in three compartments (Left, Center, Right). A conspecific is 
placed under a wire cage in one of the sides of the apparatus (either Left or Right; social 
zone), while an empty wire cage (control zone) is placed at the opposite side. The aim of the 
test is to measure the “Sociability”, that is the propensity to spend time with another 
subject, as compared to time spent alone in an identical but empty chamber.

 The videos include the image of two arenas, so you need the Multiple Arena module to 
do tracking in both arenas simultaneously. If you do not have the Multiple Arena Module, 
you can create Arena Settings with one arena and track from that arena.

 In order to acquire data with this experiment, you need a Graphics Processing Unit (GPU, 
or secondary graphics card) which supports a recent version of CUDA software.

Media files

Social approach test Trial 1.mp4

Social approach test Trial 2.mp4

experiment settings
In the Experiment Settings, we set the Number of Arenas to 2 and the Number of Subjects 
per Arena to 1 because we are going to track only one subject, that is, the test subject, not the 
subject under the wire cage.
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Under Tracked Features, Center-point, nose-point and tail-base detection is selected. The 
Body Point Detection Technique is set to Deep learning. 

note  If the GPU driver is not compatible with the CUDA version needed to use Deep 
learning, a message appears next to this option. You can only visualize the data already 
acquired (Trials 1 and 2). Another option is to install this experiment on a PC with a more 
recent graphics card.

arena settings
Two Arena Settings are defined, one for each video file, depending on in which compartment 
they placed the wire cage with the second mouse (left or right). 

 Arena Settings 1. For video Social approach test Trial 1.mp4. The social zone is in the left 
compartment.

 Arena Settings 2. For video Social approach test Trial 2.mp4. The social zone is in the right 
compartment.

In both Arena Settings, and for both arenas, each wire cage is defined as zone (social or 
control). Furthermore, a larger zone (Outer social zone and Outer control zone), is defined for 
analysis purposes (see below). 

Note that the arena does not include the part of the image where the second mouse is 
visible. This has been done to avoid that the software tracks that mouse.

When you do tracking, make sure that you choose the correct Arena Settings for that video!

trial control settings
In the beginning of the video, the operator removes the doors that divide the compartments 
in both arenas. That marks the start of the test. The Trial Control Settings includes a 
condition “Wait 6 seconds after detecting the mouse”. This has been done to ensure that 
tracking starts after the arms of the operator are no longer visible in the video.

detection settings
The method Dynamic subtraction has been used to detect the contour of the test mouse. 
Deep learning is used to find the nose-point and the tail-base point. 

In case you create new Detection Settings, under Method click Define and make sure that the 
yellow square box includes the whole body of the mouse in Arena 2.
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data profiles
The experiment includes two Data profiles:

 All data. Use this data profile for an overview of all tracks.

 Groups KO vs WT. Two fictitious groups, WT and KO, have been created, each containing 
two tracks. You can view which track belongs to which group in the Type column of the 
Trial List. Use this data profile to compare groups of test subjects.

analysis profiles
The experiment includes three Analysis profiles:

 Time spent in compartments. This profile includes a variable of type In zone to quantify 
the time that the mouse spent in the three compartments (Left, Center and Right). It is 
based on the detection of the mouse’s center point in each zone.

 Exploration of social vs control zones. This profile is based on the detection of the nose 
point and the head direction, and aims at quantifying exploration more in detail. 
 An In zone variable tells when the nose of the mouse is within the social/control zone.
 Two variables of type Head directed to zone, one for the social zone and the other for 

the control zone, measure the time that the animal’s head was directed to a zone 
(social/control) while its body center was in the outer zone (Outer social/control 
zone). This extra condition acts as a filter to exclude the instances when the animal 
was pointing to the zones of interest but was still far from them.

 Locomotory activity. This profile includes Distance moved and Velocity, to quantify the 
level of activity of the mouse.

trial statistics
Choose Analysis > Results > Statistics and Charts.

Choose a Data profile and an Analysis profile from the toolbar to visualize the results.
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group statistics
Choose Analysis > Results > Statistics and Charts then click Group Statistics and Charts. 
Select the Data profile Groups KO vs WT to view the statistics for two groups of tracks. 

integrated visualization
Choose Analysis > Results > Plot Integrated Data.

heatmaps
Choose Analysis > Results > Plot Heatmaps. Select the Data profile Groups KO vs WT and click 
Adjacent in the panel on the right. The heatmaps are based on the nose point, so you see 
exactly where exploration was directed to.

acknowledgments
We thank Dr. Giorgio Bergamini, Idorsia Pharmaceuticals, Allschwil, Switzerland, who kindly 
provided the video files.
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PhenoTyper hardware XT160

overview
This is an example of how you can use Trial Control to carry out a conditioning experiment in 
a PhenoTyper cage. 

The aim of this experiment is to teach a mouse to go from the pellet feeder on top of the 
shelter to receive a reward (a food pellet). The start of the conditioning session (“pellet 
session”) is indicated by a yellow light cue from the PhenoTyper top unit (see also trial 
control settings). In the video file, video recordings of two PhenoTyper cages have been 
combined. The top row shows Arena 1, the bottom row Arena 2. The videos on the left are the 
recordings with a normal camera, which enable you to see the yellow light come on at the 
start of the ‘pellet session’. The videos on the right show the recordings of the PhenoTyper 
top unit IR-camera. This view is used for video-tracking.

Media file

PhenoTyper hardware.mp4. Note that although the video shows two lickometers placed near 
the PhenoTypers, lickometer data are not included in this experiment.

experiment settings
The Video Source was originally set to Live tracking to acquire data and control hardware, 
and then set to From video file to allow acquisition of new trials from the video file. Under 
Trial Control Hardware, Use of Trial Control hardware is selected. 
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arena settings
In the Arena Settings, two arenas have been defined, Arena 1 (top-right) and Arena 2 
(bottom-right).

Four zone groups have been defined:

 PhenoTyperFloor. Includes the zone PhenoTyperFloor. Use 
this zone to calculate, for instance, distance moved in a 
horizontal plane (so, excluding vertical movement of the 
mouse climbing on the shelter).

 OnShelter. Includes the zone OnShelter, to calculate the time spent on top of the shelter.

 PelletZone. Includes the zone PelletZone. This zone is used to trigger the hardware action 
Drop Pellet (see trial control settings below) when the animal moves from this zone 
on top of the shelter.

 Shelter (hidden zone group). This is a special group of zone, named Hidden zone group. It 
includes a hidden zone named Shelter and its entry zone named Entry Zone 1. A hidden 
zone, together with its entry zone (or zones), allows to calculate the time spent inside 
the shelter. For more information on hidden zones, see the EthoVision XT Help.

Under Arena - Hardware mapping, a PhenoTyper top unit and a Pellet dispenser have been 
assigned to each arena.

If you wish to create a new Arena Settings profile, after selecting the video file as a 
background image adjust the Aspect ratio (728x576). 

detection settings
Dynamic Subtraction was used.

trial control settings
In the Trial Control Settings, the following procedure has been programmed. To view the 
details of actions and conditions, click the Settings buttons within the Trial Control boxes.

1. After a set time of 30 seconds (box A), tracking starts, at which moment the yellow light 
of the PhenoTyper top unit is turned on (box B) as a signal that a ‘Pellet session’ starts. A 
pellet is dropped that marks the start of the task (“Start Pellet”; box C). Next, the 
Reference ‘Start Pellet Session’ (box D) is activated. This starts the sub-rule ‘Pellet 
Session’ (box E). This sub-rule is repeated 3 times, according to what is specified in the 
Reference box.
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2. In the sub-rule ‘Pellet Session’, every time the animal moved from PelletZone to the 
OnShelter zone (box F), a pellet is dropped (box G).

3. When this has occurred 3 times, or when 5 minutes have passed since the start of the 
track (box H), the yellow light in the top unit is switched off (box I) and tracking stops.

 

data acquisition
You can re-do the trial using the same video PhenoTyper hardware.mpg. When you start 
acquisition, ignore the message There is no IO-box connected and click OK to start.

data profiles
Choose Analysis > Data Profile > Open. The sample project contains the following Data 
profiles:

 All data. The default Data profile with all data. 

 Results per zone. When this Data profile is active, the dependent variables are calculated 
for each selected zone separately.

analysis profiles
Choose Analysis > Analysis Profile > Open. The sample project contains the following 
analysis profiles:
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 In and On shelter and in pellet zone. This profile contains the variables Inside shelter, On 
shelter and In pellet zone. With these variables you can calculate the frequency and 
duration of the time spent in each zone and also the latency of entering each zone. The 
fourth variable, Drop pellet, is a variable of type Hardware command. With this variable 
you can visualize and calculate the number of pellets dropped by the Pellet dispenser 
(see also the figure under integrated visualization).

 Total distance moved and mean velocity. This profile contains the variables Distance 
moved and Velocity. With this Data profile the mean distance moved and mean velocity 
is calculated. 

 Time to complete the task. Consider the following variables:
 From first to third Drop Pellet. This is a Trial Control state based on the events “Drop 

pellet” in the subrule. You can use it for example to visualize and calculate the time 
from the first and the third Drop pellet event.

 Time to complete the task. Unlike the variable above, this is a free interval, which 
starts from the first event “Start Pellet” to the last “Drop Pellet” of the Pellet session 
(subrule). It is a measure of the time to complete the task.

analysis
Choose Analysis > Results > Statistics and Charts. Select the Analysis profile In and On shelter 
and in pellet zone and the Data profile All data. Locate the columns:

 Inside shelter. Here you find statistics for the instances when the mouse entered the 
shelter. 

 Drop pellet. Here you can see how many commands “Drop a pellet” have been given for 
each subject.

 On Shelter. Under Latency to Last, you find the time that the subject reached the top of 
the shelter for the last time. This is a measure of the time taken to complete the task. 
you can see that it took the animal in Arena 1 119.6 s to get its last reward, whereas the 
animal in Arena 2 needed 86.9 s. Hence, the animal in Arena 1 was slower than the 
animal in Arena 2 at getting the three rewards. 

 In pellet zone. Locate this column in the analysis results table, and note the difference 
between the subjects in Arena 1 and Arena 2 in the time spent in the pellet zone.

Select now the Analysis profile Total distance moved and mean velocity. The analysis output 
shows that the distance moved and velocity for the two mice. When you select the Data 
profile Results per Zone, you get the mean distance moved and velocity in each of the zones. 
When looking at the results for the zone PhenoTyperFloor, the total distance moved of the 
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animal in Arena 1 is greater than that of the animal in Arena 2. Conversely, the mean velocity 
is lower.

integrated visualization
Choose Analysis > Results > Plot Integrated Data. Choose the Data Profile and Analysis 
Profile from the lists on the toolbar. The visualization of Analysis profile In and On shelter 
and in pellet zone is shown in the next picture.
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At the bottom-right corner of the screen the Trial Control Events panel shows you when the 
trial control events took place, for example when a condition became true or a pellet drop 
was performed.

The events active at the time selected in the video are highlighted in red.

If you do not see this list, at the top-right corner click Show/Hide and select Trial Control 
Events.

acknowledgment
The experiment was made by Coen van Kaam with the help of Raymond de Heer (Delta 
Phenomics).
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DanioVision with 96 wells XT160

overview
This is an example of an experiment carried out with a DanioVision system. In this 
experiment, 96 zebrafish larvae were tracked in a well-plate. One minute after the start of 
tracking, using trial and hardware control, a light stimulus was turned on for 1 minute. After 
this minute, the light was turned off again for 1 minute and then tracking stopped. During 
live acquisition, the Trial Control protocol White Light Routine (see page 44) ensures that the 
stimuli are given at the right time. You can then compare several behavioral endpoints 
between the three phases of the trial (between light; during light; after light). To assess very 
rapid movements of the larvae, a camera frame rate of 60 frames per second (fps) was used.

Media file

DanioVision 96 wells.avi

experiment settings
In the original experiment, the Video Source was Live tracking and Use of Trial Control 
hardware was selected. The experiment was then set to track From video file so you can 
acquire your trials from the video file, using your own Arena, Trial Control and Detection 
settings.

note  If you open Acquisition, a message appears saying that EthoVision XT cannot find the 
DanioVision connected. Click Continue to go on with data acquisition.

trial list
At the top-right corner, click Show/Hide and select Variables. Choose to view:

 Treatment was created as a user-defined variable with the predefined values Treated and 
Control. 

 Subject not found and Missed samples. These are system variables. Subject not found is 
almost always 0% for Trial 1, which means that the subject was always found in each 
well, and for each frame of the video. The Missed samples is always 0%, which indicates 
that no sample was skipped.
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arena settings
Ninety-six arenas were created for the well-plates. In the Arena - Hardware Mapping 
window, the DanioVision White Light was specified.

note  Creating a zebrafish experiment is facilitated by the automatic detection of the wells. 
See the Reference Manual - DanioVision DVOC-0041 for details.

trial control settings
This sample experiment contains two Trial Control settings:

 Default. This is the default Start-Stop trial control rule. You can use this to acquire data 
without controlling the DanioVision White Light.

 White Light Routine. This was used for acquiring Trial 1. The following procedure was 
programmed: 
 After a time of 1 minute (Condition box “Time (1)”, see A in the figure below), a 

Reference (see the Reference box, B) activated the sub-rule White light routine (Rule 
Begin box, see C). 

 In this sub-rule, the white light was turned on to 100% of its maximum intensity in 5 
seconds (Action box “White Light On”, see D) and was on for 1 minute (Condition box 
“Time (2)”, see E). 

 Next, the white light was turned off from 100% to 0% in 1 second (Action box “White 
Light Off”, F).

 After a time of 1 minute (Condition box “Time (3)”, G) tracking was stopped (Action 
box “Stop track” H).

TIP  Click the Settings buttons to see the details of a Trial Control box.
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detection settings
The DanioVision method was used. A sample rate of 60 samples per second was used.

track smoothing profiles
Choose Acquisition > Track Smoothing Profiles > Open. 

A track smoothing profile MDM 0.2 mm has been defined in which a Direct Minimal Distance 
Moved (MDM) filter is used. This removes sample-to sample distances shorter than 0.2 mm. 
For the DanioVision set-up a Minimal Distance Moved filter of 0.2 mm is recommended for a 
good estimate of distance moved (swim path length).

If you want to visualize and calculate results without this filter, choose Acquisition > Track 
Smoothing Profile > New. In the newly-created profile Track Smoothing profile 1, all filters 
are disabled.

data profiles
Choose Analysis > Data Profile > Open. The project contains the following Data profiles: 

 All data, Treated vs. Control. Contains entire tracks, but split in two groups based on the 
value of the Treatment independent variable, Treated or Control.

 Intervals based on White Light state. This contains three separate Result boxes are 
defined. Using the Nesting function Trial Control State, the tracks are split in three 
intervals (each represented by a Result box): 
– 1. Before White light goes on. This interval goes from the start of the track to the 

moment that the White Light On command was activated (box D in the figure).
– 2. White light on. This interval goes from when the command “White Light On” was 

activated (box D in the figure) to when “White Light Off” was activated (box F).
– 3. After white light goes off. This interval goes from when “White Light Off” was 

activated (box F) to the stop of the track (box H). 

In this Data profile, Treated and Control subjects are analyzed together.

 Before vs. after White light on. This is an example of how you can use the Free Interval 
function to select a segment of the tracks depending on a combination of time and 
events. With this Data profile you compare the two seconds immediately before the 
white light goes on and the two seconds immediately after it goes on. The Data profile 
also splits the data further based on control vs. treated subjects.
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analysis profiles
Choose Analysis > Analysis Profile > Open. The project contains the following analysis 
profiles: 

 Distance moved and Velocity. With the mean and total Distance moved and the mean 
Velocity. 

 Movement. In this Analysis profile, the frequency, duration and latency of the behavioral 
state Movement are calculated for each subject, which is a measure of their locomotor 
activity. Use the Data profile Intervals based on White Light state to see in which time 
period the light was on (see the figure under integrated visualization below).

 Rotation. The variable CW Rotation counts the number of clockwise rotations, and CCW 
Rotation calculates the number of counter-clockwise rotations.

 Turn angle. To quantify the amount of turning (in degrees) per sample. 

integrated visualization
important  Visualizing the video and analysis results for 96 subjects is very processor 
intensive. Close all other software running on your computer before taking this step. 

Choose Analysis > Results > Plot Integrated Data. Choose the Data Profile, Analysis Profile 
and Result from the lists on the toolbar. 

The figure below shows the tracks and the variables when you select:

 The Data profile Intervals based on white light state.

 The Analysis profile Movement.

 The Result 1. Before White Light goes on.

Yellow and red tracks are of Treated and Control subjects, respectively. 

Choose another item from the third list to view the results for another interval. Note that 
the third list is only available if your Data profile contains two or more Result boxes.
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statistics
Choose Analysis > Results > Statistics & Charts. 

When you open the Group Statistics & Charts tab and select the Data profile Interval based 
on white light state and the Analysis profile Distance moved and Velocity, you see the 
statistics of distance moved and velocity for each interval 1. Before white light on, 2. White 
Light on, and 3. After white light off. The decrease in distance moved (swim path length) and 
velocity in the second interval indicates that turning the white light had an effect on the 
activity levels of the zebrafish larvae.

A similar result can be seen when you select the Data profile Before vs. after White light goes 
on.

Furthermore:

 Select the Data profile Intervals based on white light state and the Analysis profile 
Rotation or Movement. There you see that rotation and frequency of movement 
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significantly decreased after turning on the white light, and strongly increased after 
turning it off again.

 Select the Data profile All data, Treated vs. Control and the Analysis profile Rotation or 
Turn Angle. You see some difference between Treated and Control subjects in the average 
values of rotation (clockwise and counterclockwise) and turn angle, although this 
difference is probably not statistically significant.

acknowledgment
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for more information
See the Reference Manual - DanioVision Observation Chamber DVOC-0041. To open this 
manual, choose Apps > Noldus > EthoVision XT 16 Other Documentation.
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DanioVision with camera zoomed into four 
wells XT160

overview
This is an example of an experiment carried out with a DanioVision system using a camera 
with a zoom lens. The image of a 96 well plate was zoomed in to four wells. 

In this experiment, four zebrafish larvae (two controls, two treated) were tracked for about 
ten minutes. The aim of the experiment was to compare activity and movement parameters 
(including rotation frequency) in the two experimental groups. 

Media file

DanioVision four wells.avi

experiment settings
The Video Source was set to From video file. Because the four wells are independent 
replicates, the number of Arenas was set to 4 and the number of Subjects per Arena was 1.

trial list
Choose Setup > Trial List. A user defined variable Treatment is defined with the predefined 
values Treated and Control. Each subject is assigned either value. 

arena settings
Four arenas were created for the well-plates. Each arena was divided into a border zone and 
a center zone.

tip  In EthoVision XT, creating a zebrafish experiment is facilitated by pre-defined templates 
in which settings, including arena settings, have already been made to enable you to set up 
an experiment more quickly. Also, adjusting arenas is easy with the Multiple Arena Setup. 
See the EthoVision XT Help for details.
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trial control settings
In the Trial Control Settings profile named Default, tracking was set to start as soon as the 
trial was started, that is, when one clicks the Start trial button. Tracking lasts until the end of 
the video file.

detection settings
In the Detection Settings named Detection Settings 1, the DanioVision method was selected. 
To remove some noise the subjects’ contour was filtered using the Contour erosion and 
Contour dilation.

track smoothing profiles
Under Track Smoothing Profiles, besides a profile named No Smoothing with no smoothing 
selected, a second profile, MDM 0.2 mm is defined (MDM = Minimal Distance Moved). When 
you use this track smoothing profile, data points with a distance from the previous point of 
less than 0.2 mm are set to the previous position. This removes a large part of the false 
movements of the subject’s center point which do not correspond to actual movement of the 
fish. We recommend using this filter for the DanioVision set-up. 

data profiles
Choose Analysis > Data Profile > Open. The experiment has the following Data profiles:

 All Data. The default Data profile with all the data.

 Treated vs. Control vs. All data, with time bins. To compare treated and control animals in 
1-minute intervals. 

 Treated vs. Control vs. All data, no time bins. To compare treated and control animals 
throughout the whole test duration.

For both Treated vs. Control Data profiles, the Result box All data allows you to view the 
results when pooling the data of the two treatment levels.
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analysis profiles
Choose Analysis > Data Profile > Open. The experiment contains four Analysis profiles:

 Distance, Time & Movement. In this Analysis profile, the total Distance Moved and the 
mean Velocity are calculated. Also, the frequency, duration, percentage of time spent and 
latency of the behavioral state Movement are calculated for each zebrafish larvae, which 
is a measure for their activity. 

 Path shape. In this Analysis profile, the path shape of the larvae is determined by 
calculation of the mean relative Turn Angle and the mean relative Angular Velocity. 

 Rotation. In this Analysis profile, the variable CW Rotation counts the number of 
clockwise rotations, CCW Rotation calculates the number of counter-clockwise rotations. 

 In zone - In this Analysis profile, the time until the first visit and the frequency, duration 
and percentage of time spent are calculated for the center zone and border zone. 

integrated visualization
Choose Analysis > Results > Plot Integrated data.

On the toolbar you can choose which of the treatments to display (Treatment, Control or All 
data). You can also choose other Analysis profiles, Data profiles or track smoothing profiles 
from the lists on the toolbar.

The next figure shows the visualization of the Analysis profile Rotation. The animal in Arena 
1 (top left in the video) has just completed a counter-clock wise (CCW) rotation. This is 
marked with the vertical segment in the first plot, CCW Rotation. 

Tracks of Control and Treated subjects are visualized in different colors. To change colors, click 
the Colors tab on the right-hand panel. 
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analysis
Choose Analysis > Results > Statistics & Charts, then click the Grouped Statistics and Charts 
tab. Select the Data profile and the Analysis profile you want to use from the toolbar.

For example, when selecting the Data profile Treated vs. Control vs. All data, no time bins, 
and the Analysis profile Rotation, the counts of rotations are shown for the two treatment 
groups separately and for all the trials together.
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 DanioVision with camera zoomed into four wells XT160 53



Barnes Maze XT160

overview
This sample experiment shows you how you can use the dependent variable Target visits and 
errors, to analyze the animal’s path in a memory test paradigm where certain zones are 
defined as targets. For more information, see the EthoVision XT Help.

In a Barnes maze experiment, a mouse or rat tends to escape from the brightly lit surface of 
the maze. One of the holes gives entrance to an escape box, which is a dark shelter under the 
hole board. The animal is trained to find the escape box. During this training phase, the 
number of visits to other holes should decrease rapidly, which is a measure for learning 
ability. 

In the probe phase, the escape box is removed. The time to reach the hole where the escape 
box previously was is determined, together with the number of visits to other holes and the 
total distance moved. 

In this example, two train trials and a probe trial were carried out with a mouse. The animal’s 
center-point, nose-point and tail-base were tracked. 

Media files

 Barnes maze train trial 1.mpg

 Barnes maze train trial 2.mpg

 Barnes maze probe trial.mpg

experiment settings
The Video Source was set to From video file. As Tracked Features, Center-point, Nose-point, 
and Tail-base detection is selected.

arena settings
Since the position of the holes is slightly different in the three videos, the project contains 
separate arena settings for each video. Each arena settings contains:

 H1 to H11. Zones that cover the holes that do not contain (or did not contain) the escape 
box. 
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 Other holes together. A cumulative zone with the zones H1 to H11. You can use this zone 
to calculate and visualize the total time spent exploring all non-target holes.

 Target hole. A hidden zone that covers the hole with the escape box in trials 1 and 2. If the 
animal enters the entry zone and then disappears, EthoVision XT considers it to be in the 
hidden zone. 

 Target hole probe trial. A zone around the hole that previously contained the escape box. 
This zone is used in trial 3.

If you wish to create a new Arena Settings profile, after selecting the video file as a 
background image, adjust the Aspect ratio (768 x 576). 

trial control settings
The experiment contains trial control settings Max. track duration 3 min. The track starts 
when the mouse was detected in the arena for two seconds. It ends either after three 
minutes, or when the mouse has been in the hidden zone Target hole for one second. 

detection settings
Since the lighting and the background differs per video, separate detection settings were 
made for each video. Dynamic Subtraction and Rodents / Default were used. 

trial list
The trial list contains the following user-defined variables:

 Treatment. with the predefined values Treated and Control. 

 Animal ID. a numerical variable to identify the mice, for example 1, 2, etc.

 Type of Trial. with the predefined values Training and Probe.

track smoothing profiles
The experiment contains a No Smoothing profile, and one with Lowess Smoothing on. 
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data profiles
Choose Analysis > Data Profile > Open. The project contains two Data profiles. 

 All data. This is the default Data profile that contains all tracks.

 Training vs. Probe. The tracks are grouped, based on the independent variable Type of 
trial. Two groups of tracks are created: 
 Training. With the two training trials. 
 Probe. With the probe trial.

analysis profiles
Choose Analysis > Analysis Profile > Open. The project contains two analysis profiles. 

 Distance & Velocity. with the total distance moved and the mean velocity.

 Hole visits. This profile contains two variables.
 Target visits and errors. Double-click this variable to see how it is set up. 

Under Target zones, the target holes for probe and training trials are selected. Under 
Non-target zones, all other holes H1 to H11 are selected (note: do not select Other 
holes together. This zone can be used in the variable Hole exploration time; see 
below). 
On the Body points tab, Nose-point is selected, that is, a visit is calculated when the 
nose point is detected within the corresponding zone.
With this variable you can calculate (1) the number of visits to the targets (including 
revisits), (2) the number of visits to non-target holes, (3) the latency to the first visit to 
the target holes. In probe trials, revisits to target holes and all visits to non-target 
holes are considered as errors.
Note that this variable also includes a Zone exit threshold. That means that, when the 
nose-point is just outside one of the hole zones, but within the threshold distance, 
the nose-point is still considered in the zone. Therefore, the zone visit only ends when 
the nose-point is found further than the threshold distance. You can use the Zone exit 
threshold to avoid that multiple nose pokes are considered as separate visits.

 Hole exploration time. This is an instance of the dependent variable In zone. You can 
use this variable to calculate the total time that the animal’s nose was detected 
inside each hole, or all holes together. For this purpose, the cumulative zone Other 
holes together is also selected in the variable’s settings (see under In the following 
zones).

 Error visits > 1s. To determine instances of zone visits that last longer than a specific 
time, a Free Interval was used, based on the dependent variable In Zone. The start 
condition was defined as the moment the animal’s nose-point was in one of the error 
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zones for more than 1 s. The stop condition was defined as the moment the animal’s 
nose point was no longer in the error zone. 

When you plot this in the Integrated Visualization (Choose Analyze > Results > Plot 
Integrated data), you see that only the zone visits that lasted longer than 1 second are 
plotted. 

Note that the intervals start one second (or the time specified in the start condition of 
the Free Interval Settings) after the animal actually enters the zones. So if you want to 
calculate the durations of these intervals, add this time to the values EthoVision XT gives. 
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integrated visualization
Choose Analysis > Results > Plot Integrated Data. 

The visualization of the Analysis profile Hole visits is shown in the figure below. On the 
toolbar you can choose which of the trial types to display (Training vs. Probe or All data). You 
can also choose other analysis profiles, Data profiles or track smoothing profiles from the 
lists on the toolbar.

 The first plot shows the target visits and errors.

 The second plot shows the hole exploration time. In the probe trial (Trial 3), the animal 
visits several non-target holes.

 he third plot shows the visits to the error zones that lasted more than 1 second. See 
analysis profiles on page 56 for a detailed explanation. 
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trial statistics
Choose Analysis > Results > Statistics & Charts. Select the Data profile and the Analysis 
profile you want to use from the toolbar.

For example, when selecting the Data profile Training vs. probe, and the Analysis profile Hole 
visits, you can see that in the first training trial the subject made a total of 9 errors (5 non-
target first visits and 4 non-target revisits), while in the second training trial the mouse 
walked directly to Target hole and made no errors.

Latency to target hole visits

Locate the column Nose point / Target first visits. Check the values under Latency to First. In 
the first training trial the mouse reached the target hole after 63.8 seconds, while in the 
second trial it reached the target hole in less than 8 seconds.

In the probe trial, the mouse reached the target hole after 11 seconds. 

Distance and velocity

When you select the analysis profile Distance & Velocity, you can see that the walking path 
of the mouse before reaching the target hole was much longer in the first training trial than 
in the second training trial.

acknowledgment
Video material by courtesy of Dr. C.J.Y. Hubens (Leiden Academic Centre for Drug Research, 
Leiden University, The Netherlands), who is gratefully acknowledged.
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Mouse Behavior Recognition in Open Field 
XT160

overview
The aim of this sample experiment is to demonstrate how EthoVision XT automatically 
detects various behaviors of mice, like rearing, walking and sniffing.

Media file

Mouse Behavior Recognition in Open Field.mpg.

Note

To work with the Behavior Recognition function, you need the Mouse Behavior Recognition 
Module. For information about performance and the limitations of the Behavior Recognition 
function, see Behavior Recognition in the EthoVision XT Help. See also the paper by van Dam 
et al. (2013). An automated system for the recognition of various specific rat behaviours. 
Journal of Neuroscience Methods 218,(2), 214–224.

experiment settings
Under Analysis Options, Behavior Recognition is selected. The options are selected that 
apply to the video, thus Arena walls is selected, not Feeder and Drinking bottle, which are 
not present in the cage. For the same reason, the additional options available when clicking 
Settings are not selected.

arena settings
In the Arena Settings, two zone groups are defined: 

 Zone Group 1, with two zones, Center and Border.

 Wall Zones, with a zone called Wall Zone 1. This zone is important for automatic 
detection of rearing. It is defined by drawing a polyline shape around the open field floor, 
excluding the Plexiglas blocks at two of the corners. Note that the zone label is placed 
outside the shape, and points to the walls.
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detection settings
A Detection Settings profile has been defined:

 Under Video, the Sample rate is set to 29.97, the maximum for that video. Behavior 
Recognition works with a sample rate of 25 samples/s or higher.

 Under Advanced, Contour erosion/dilation is set to the minimum. If you create your own 
detection settings, we advise you not to increase contour erosion/dilation as this might 
affect recognition of subtle behaviors, like sniffing.

 Behavior settings are set under Behavior Recognition. If you create your own settings, 
click the Define Subject Properties button, play the video up to when the animal walks 
with a normal posture, and click Grab.
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For details, see Detection Settings for Behavior Recognition in the EthoVision XT Help. 

trial control settings
The settings in Trial Control Settings 1 specify that EthoVision XT waits three seconds after 
the mouse has been detected in the arena, before it starts actual tracking. This is because 
the Behavior Recognition function needs a few seconds of data before being able to detect 
behaviors. 

Without the additional Time condition, the first three seconds of the track would not be 
scored.

data profiles
Choose Analysis > Data Profile > Open. The experiment contains three Data profiles.

 All data. The default Data profile without any filtering or nesting criteria. Use this profile 
to analyze and visualize the whole data set.

 When rearing, When sniffing. These two Data profiles select the track segments in which 
Rearing (supported or unsupported) and Sniffing were detected, respectively. Use these 
Data profiles to produce heatmaps. The resulting heatmap shows where that behavior 
occurred.

heatmaps
Choose Analysis > Results > Plot Heatmaps. Select the Data profile When grooming or When 
sniffing. The heatmap indicates where that behavior took place. 
62  Mouse Behavior Recognition in Open Field XT160



analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment contains two Analysis profiles.

 Behaviors and probability. Specifies all ten behaviors that can be detected. Behaviors are 
analyzed with the default settings. The last item in the list is Behavior probability of the 
various behaviors. Note that the behavior scored at a certain time is the one with the 
highest probability. You can modify the Analysis profile in such a way that a behavior is 
only scored when its probability exceeds a specific value, for example 90%.

 Rearing (merged). This is an example of how you can analyze two behaviors as one. 
Rearing supported and Rearing unsupported are merged in one behavior, renamed 
Rearing (merged). The Behavior probability of the two Rearing behaviors is also specified.

integrated visualization
Choose Analysis > Results > Plot Integrated Data.

 Select the Analysis profile Behaviors and probability. There you can see the instances of 
the behaviors detected. The plot at the bottom shows the probability of the behaviors.
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tip  Use Behavior probability to check whether some instances of behavior have low 
probability. To remove those instances, in the Analysis profile double-click that behavior 
and under Behavior decision method specify Probability greater than.

 Select the Analysis profile Rearing (merged behaviors) to see how different behaviors are 
merged in one category.

acknowledgment
Video was provided by Dr. T. van Groen, Dept. Cell Biology, University of Alabama, 
Birmingham, Alabama, USA.
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Mouse Behavior Recognition in Social 
Discrimination XT160

overview
The aim of this sample experiment is to demonstrate how EthoVision XT can automatically 
detect various behaviors of a mouse, like sniffing, digging and grooming. 

Media file

Mouse Behavior Recognition in Social Discrimination.avi.

Note

To work with the Behavior Recognition function, you need the Mouse Behavior Recognition 
Module. For information about performance and the limitations of the Behavior Recognition 
function, see Behavior Recognition in the EthoVision XT Help. See also the paper by van Dam 
et al. (2013). An automated system for the recognition of various specific rat behaviours. 
Journal of Neuroscience Methods 218,(2), 214–224.

experiment settings
Although the video shows two mice in the same cage, only one was tracked. Therefore, under 
Number of Subjects, 1 is selected.

Under Analysis Options, Behavior Recognition is selected. The options are selected that 
apply to the video, thus Arena walls is selected, not Feeder and Drinking bottle which are not 
present in the cage. When clicking the Settings button, the additional option Bedding 
present is selected.

arena settings
The test cage has been divided in three compartments: a central compartment where the 
focal male mouse is confined, and two side compartments. In the right compartment a 
female mouse is placed to serve as a social stimulus. 

In the Arena Settings, only the central compartment of the home cage has been defined as 
Arena, because that is where the focal subject is going to be moving. The other subject, 
confined in the right compartment, is not tracked. 
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A zone group Wall Zones is defined. It contains one zone called Wall Zone 1. This zone is 
important for automatic detection of rearing. It is defined by drawing a polyline shape 
around the open field floor. Note that the zone label is placed outside the shape, and points 
to the walls. 

A zone group is also defined with two zones, Social side (right) and Non-social side (left). This 
way you can split your results based on the position of the nose point in one of the two 
zones. For example, to calculate the total duration of Sniffing when the mouse’s nose was in 
the zone “Social”.

note  If you exchange the social with the non-social sides, by placing the female mouse in 
the left compartment, duplicate the Arena settings and swap the labels of the two zones. 
Use this new Arena Settings for when the female mouse is placed in the left compartment. 
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detection settings
A Detection Settings profile has been defined:

 Under Video, the Sample rate is set to 25, the maximum for that video. This is compulsory 
for behavior recognition.

 Under Advanced, both Contour erosion and Contour dilation are set to 2. If you create 
your own detection settings, we advise you not to increase contour erosion/dilation as 
this might affect recognition of subtle behaviors, like sniffing.

 Under Behavior Recognition, you find the settings for the subject size and posture. If you 
create your own settings, click the Define Subject Properties button, play the video up to 
when the animal walks with a normal posture, and click Grab.

For details, see Detection Settings for Behavior Recognition in the EthoVision XT Help. 

trial control settings
The settings in Trial Control Settings 1 specify that EthoVision XT waits three seconds after 
the mouse has been detected in the arena, before it starts actual tracking. This is because 
the Behavior Recognition function needs a few seconds of data before being able to detect 
behaviors. Without the additional Time condition, the first three seconds of the track would 
not be scored.
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acquisition
During data acquisition, you can view live statistics of events and behaviors of the subjects. 
In the Acquisition screen, after starting a trial, click the Dependent Variables tab. There you 
can view how many times and for how long the mouse’s nose was detected in the zone 
Social side (highlighted on the video window). To view more dependent variables, at the top-
right corner of the screen click Show/Hide > Show Dependent Variable.

data profiles
Choose Analysis > Data Profile > Open. The experiment contains three Data profiles.

 All data. The default Data profile without any filtering or nesting criteria. Use this profile 
to analyze and visualize the whole data set.

 When sniffing, When digging. These two Data profiles select the track segments in 
which Sniffing and Digging were detected, respectively. Use these Data profiles to 
produce heatmaps. The resulting heatmap shows where that behavior occurred. The 
Data profile When sniffing is further divided into two result boxes, one for each side of 
the cage. This means that you can analyze sniffing when the nose point was in one of the 
sides, Social vs. Non social.
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analysis profiles
Choose Analysis > Analysis Profile > Open. The experiment contains three Analysis profiles.

 Behaviors and probability. Specifies the behaviors that can be detected automatically. 
Behaviors are analyzed with the default settings (that is, using the criteria of the 
behavior recognition algorithm). In this sample experiment we focus on behaviors like 
Digging, Grooming and Sniffing. Behavior probability is defined for those behaviors but 
you can also select it for others. This gives you an idea of the level of confidence that 
EthoVision XT has when scoring a particular instance of one of those behaviors. Double-
click this item and specify to view the probability of the remaining behaviors. The last 
item in the list is for when no behavior was scored; usually this is at the end of the video; 
to check this, see integrated visualization.

 Sniffing. This is an example of how you can filter instances of a behavior based on their 
probability. It contains the same behavior, Sniffing, evaluated with two criteria: default 
and with probability higher than 75%. The second means that Sniffing is scored if the 
probability of Sniffing is higher than 75%. The probability of Sniffing is also specified.

 Sitting still with nose in social zone. This is an example of a Multi condition variable. It 
combines two dependent variables, In zone (Nose point in social zone) and Movement 
(Not moving). The thresholds for Moving and Not moving are 4.00 and 3.75 cm/s 
respectively. The analysis profile also contains the dependent variable Velocity of center 
point. If you plot the dependent variables in an integrated visualization, you can use the 
values of Velocity to fine tune the settings for Movement. 

heatmaps
Choose Analysis > Results > Plot Heatmaps. Select the Data profile When sniffing. The 
heatmap indicate where sniffing took place.
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integrated visualization
Choose Analysis > Results > Plot Integrated Data.

 Select the Analysis profile Behaviors and probability. There you can see the instances of 
the behaviors detected. The plot Behavior probability shows how the probability of a 
behavior changes with time. See the definition of probability in the analysis profiles.

tip  Use this chart to check whether some instances of behavior have low probability (= 
high uncertainty). To remove those instances, in the Analysis profile double-click that 
behavior and under Behavior decision method specify Probability greater than.

 Select the Data profile All data and the Analysis profile Sniffing to see the effect of 
filtering instances of Sniffing based on probability. 

 Select the Data profile All data and the Analysis profile Sitting still with nose in social 
zone to see when the animal was exploring the social zone without moving. 

acknowledgment
Video was provided by Prof. Martien Kas, Department of Neurobiology, University of 
Groningen, The Netherlands.
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Rat Behavior Recognition in PhenoTyper 
XT160

overview
The aim of this sample experiment is to demonstrate how EthoVision XT can automatically 
detect various behaviors of a rat, like rearing, grooming, sniffing, drinking and eating, in a 
home-cage environment.

Media file

Rat Behavior Recognition in PhenoTyper.mpg.

Note

To work with the Behavior Recognition function, you need the Rat Behavior Recognition 
Module. For information about performance and the limitations of the Behavior Recognition 
function, see Behavior Recognition in the EthoVision XT Help. See also the paper by van Dam 
et al. (2013). An automated system for the recognition of various specific rat behaviours. 
Journal of Neuroscience Methods 218,(2), 214–224.

experiment settings
Under Analysis Options, Behavior Recognition is selected. All options for Rat Behavior 
Recognition are selected: Feeder, Drinking bottle and Arena walls.

arena settings
In the Arena Settings, four zone groups are defined: 

 Zone Group 1, with no zones defined. You can use this layer to define for example the 
Center and Border zones of PhenoTyper.

 Drinking Spout Points. Because PhenoTyper for rats has two drinking bottles, two 
drinking spout points are defined for detection of drinking, Spout 1 and Spout 2.
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 Feeder Zones. Includes one zone, Feeder Zone 1 for detecting feeding behavior.
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 Wall Zones. It includes one zone, Wall Zone 1. This zone is important for automatic 
detection of rearing at the walls. It is defined by drawing a polyline shape around the 
PhenoTyper’s floor. Note that the zone label is placed outside the shape, and points to 
the walls.

detection settings
A Detection Settings profile has been defined:

 Under Video, the Sample rate is set to 25, the maximum for that video. This is compulsory 
for behavior recognition.

 Behavior settings are set under Behavior Recognition. If you create your own settings, 
click the Define Subject Properties button, play the video up to when the animal walks 
with a normal posture, and click Grab.
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 Under Advanced, Contour erosion/dilation is set to the minimum. If you create your own 
detection settings, we advise you not to increase contour erosion/dilation as this might 
affect recognition of subtle behaviors, like sniffing.

For details, see Detection Settings for Behavior Recognition in the EthoVision XT Help. 

trial control settings
The settings in Trial Control Settings 1 specify that EthoVision XT waits three seconds after 
the rat has been detected in the arena, before it starts actual tracking. This is because the 
Behavior Recognition function needs a few seconds of data before being able to detect 
behaviors. Without the additional Time condition, the first three seconds of the track would 
not be scored.

data profiles
Choose Analysis > Data profile > Open. The experiment contains two Data profiles.

 All data. The default Data profile without any filtering or nesting criteria. Use this profile 
to analyze and visualize the whole data set.

 When sniffing. This Data profile selects the track segments in which Sniffing was 
detected for more than half second (click the Settings button in the Nest box to view the 
settings). With this profile activated, you can create a heatmap to show where Sniffing 
occurred.

tip  Choose Analysis > Data Profile > New and create a similar Data profile for when the 
rat was grooming or rearing.
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analysis profiles
Choose Analysis > Analysis profile > Open.

Behaviors and probability. Specifies all ten behaviors that can be detected, plus their 
probability (last item in the list). Some behaviors are analyzed with the default settings (that 
is, using the criteria of the behavior recognition algorithm), others with more restrictive 
criteria, for example when the behavior instance is longer than a certain time, or its 
probability is higher than 90%. Modify those settings and see what changes in the behavior 
visualization.

tip  Create a Merged behavior to analyze two or more behavioral categories as one.

integrated visualization
Choose Analysis > Results > Plot Integrated Data.

Select the Analysis profile Behaviors and probability. There you can see the instances of the 
behaviors detected. The plot at the bottom shows the probability of the single behaviors. 
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tip  Use this chart to check whether some instances of behavior have low probability. To 
remove those instances, in the Analysis profile double-click that behavior and under 
Behavior decision method specify Probability greater than.

heatmaps
Choose Analysis > Results > Plot Heatmaps. Select the Data profile When sniffing. The 
heatmap indicate where that behavior took place. 

acknowledgment
Video was provided by Dr. Johanneke van der Harst, Delta Phenomics, The Netherlands.
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Subject Counter with JavaScript XT160

You can find this sample experiment on your installation USB stick, under Utilities\JavaScript 
custom variables.

overview
This sample experiment provides an example of the capabilities of JavaScript code 
embedded in EthoVision XT, which you can use to further analyze your raw data. In this 
sample experiment a group of five zebrafish is tracked and the researcher wants to count 
how many fish are in each quadrant at any time, and quantify the time that all the fish swim 
together. For this, JavaScript code processes the raw data (position of each fish) and 
calculates the output variables (see Analysis profiles below).

Video file

Zebrafish shoal 5 fish.mp4

experiment settings
The experiment is set to offline tracking. Under Video Source, the option From video file is 
selected.

The center point of each fish is tracked, therefore under Tracked Features, the option Center-
point detection is selected.

arena settings
The arena has been divided in four quadrants, named Zone 1 to Zone 4.

detection settings
The method Dynamic Subtraction is used for body detection. The fish are not individually 
marked, so under Subject Identification the option Unmarked subjects is selected.
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data profiles
Next to the default Data profile, a second Data profile has been made: One subject (for a 
simpler results table). This profile makes the results table simpler when visualizing the 
variables that count subjects. When counting the subjects in a zone, the output is applied to 
each subject, and this makes the results redundant, since the value will be shown five times 
(once per subject). 

Use this profile when visualizing the statistics of the number of subjects in the various 
zones.

analysis profiles
Besides the default Analysis profile with distance and velocity, four profiles have been 
created.

 JS Continuous - Number of subjects in 4 quadrants. This profile contains four JavaScript 
continuous variables. Here “continuous” means that the number of subjects in each zone 
is updated at each sample.

 JS Continuous - Subject coordinates. This is another example of the use of JavaScript 
code. The variables contain the x, y coordinates of the subject, respectively. Using 
JavaScript functions and commands you can create additional variables which process 
that data.

 JS States - All fish in one quadrant. The variables in this profiles are state variables, 
meaning that the value can be 0 of 1. Use state variables to calculate the time that the 
fish are all in a particular zone, or any zone, or the latency of the first occurrence of the 
event “all fish in a zone”.

 JS Continuous - Ratio of Subjects. This is another example of how you can extract 
additional information from data like “subject in zone”. A JavaScript variable calculates 
the ratio of the number of subjects swimming in Zone 1 to the total number of subjects. 
Because this is a JavaScript continuous variable, the ratio is updated at each sample.

integrated visualization
Choose Results > Plot Integrated Data.
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