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EthoVision XT sample experiments 

sample experiments available 

All EthoVision XT sample experiments are available on my.noldus.com. 

⚫ Morris water maze XT190 

This experiment is installed by default when you install EthoVision XT. You can find it in 

C:\Users\Public\Documents\Noldus\EthoVision XT\Experiments\Sample Experiments. 

If you do not find this file, do one of the following: 

• If you have the installation files of EthoVision XT, run the Setup file (*.exe), select 

Modify and choose to install the sample experiment.  

• Go to my.noldus.com and download the sample experiment Morris water maze test 

XT190.evz and its documentation EthoVision XT 19 - Description of sample 

experiment - Morris water maze.pdf. 

⚫ Open Field test XT190                      page 5 
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⚫ Novel Object Recognition test with Deep Learning XT190        15 
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Note  Not all experiments may be available at the time you have downloaded this document. You 

can, however, download and use older versions (e.g. Open Field test XT175). Check our web site 

regularly for more sample experiments. 

For more information 

The EthoVision XT 19 - Application Manual.pdf contains useful information on many of the 

tests listed above. You can find this manual in All Apps > Noldus > EthoVision XT 19 Other 

Documentation. You can also find this manual on the my.noldus web portal. 

HOW TO USE THE SAMPLE EXPERIMENTS 

1. To download the sample experiments, browse to my.noldus.com, log in (or create an 

account first), open the Downloads page and under EthoVision XT choose Sample 

experiments. Always copy the backup files (*.evz) to your computer first. 

2. In EthoVision XT, choose File > Restore Backup, or in the EthoVision Startup window, 

choose Restore sample experiment. 

 

3. Browse to the backup file that you want to restore and click Open. 

4. In the next step you must specify where to save the experiment. The default experiment 

location is: 

⚫ If you purchased a PC with EthoVision XT: 

D:\Noldus\EthoVision XT\Experiments. 

⚫ In other cases: 

C:\Users\Public\Documents\Noldus\EthoVision XT\Experiments. 

Click OK. The experiment is restored and opens automatically on your screen. 

Notes 

⚫ The video files are stored in the Media Files subfolder of the experiment’s folder. 

⚫ Some sample experiments are based on Deep learning. This technique can only work with a 

recent graphics card (GPU) and with up-to-date drivers installed on your PC. If your GPU is 

not compatible, you can still explore the data already acquired. 
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Open Field test XT190 

OVERVIEW 

The Open field test is an experimental test used to assay general locomotor activity levels, 

anxiety, and willingness to explore in rodents. In this experiment, EthoVision XT is set to track 

the nose, center and tail-base points of mice of different colors: in Trial 1, a dark (C57BL/ 6J) 

mouse; in Trial 2, a white (ICR) mouse. 

Media Files 

Dark mouse.mpg, White mouse.mpg. 

ARENA SETTINGS 

In the Arena Settings, the open field is divided into two zones, Center and Border. Rodents 

typically prefer to spend time in enclosed spaces and will therefore tend to spend more time in 

the Border (safe zone) versus the Center (less safe zone). 

An additional zone is defined for the Wall of the open field. You can use this zone to estimate: 

⚫ Thigmotaxis, when the mouse’s center point is at short distance from the walls. For this 

purpose, use the Analysis profile Distance from Wall zone. 

⚫ Sniffing/Rearing at the walls, when the mouse’s nose is detected within the Wall zone.  

For this purpose, use the Analysis profile Nose over Wall zone. 

TRIAL CONTROL SETTINGS 

The Trial Control Settings Trial Control Settings 1 has been defined so that tracking starts 

after the mouse has been detected for 1 s in the arena, and lasts until the end of the video file. 

DETECTION SETTINGS 

The experiment contains two Detection Settings profiles: 

⚫ Dark mouse. Uses Dynamic subtraction as a method for finding the mouse of a white 

background. Use this profile to track from the video file Dark mouse. 
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⚫ White mouse. This Detection Settings profiles uses Differencing as a method to find the 

mouse. The reason is that other detection methods would not be able to find the mouse’s 

head when the animal rears at the wall, because of the low level of contrast with the white 

wall. However, Differencing can pick very subtle changes in the image and in most cases can 

find the whole contour of the mouse. 

 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment has three Data profiles: 

⚫ All data. This is a default Data profile to analyze all tracks together, without any filtering or 

nesting criteria. 

⚫ With time bins. Data are split in one-minute time bins. Use this Data profile to view 

temporal changes in the behavior of the subject. 

⚫ Groups. This Data profile is an example of how you can group tracks, for example to all 

trials with the dark mouse vs. all trials with the white mouse. Use this Data profile when 

you track multiple times from the same video file. Start tracking at different times of the 

video to create some within-group variation in the results. 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment has three Data profiles: 

⚫ Distance and velocity. This profile contains variables to quantify locomotor behavior, for 

example to calculate the mean velocity and the total distance moved of the animal's center-

point. 

⚫ JS body length. This is an example of a custom variable created with JavaScript code. It 

uses EthoVision XT raw data to calculate the length of the mouse (from nose to tail-base) at 

each sample time. Plot this variable with Integrated Visualization to see how this variable 

varies with behavior (walking vs. sitting/grooming, etc.). 
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With JavaScript custom variables, you can extract a wealth of additional information on the 

behavior of your subjects. For more details, see the EthoVision XT Help. 

⚫ Crossings. This profile contains a variable of type In zone that measures how often the 

mouse crosses the center of the open field. 

⚫ Distance from walls. This profile contains a variable of type Distance to zone for 

calculating the average distance of the mouse to the walls. 

⚫ Nose over Wall zone. This profile contains a variable of type In zone, which measures the 

time that the mouse’s nose is within the wall zone. This variable estimates the time that the 

subject rears at the walls. 

tip  With the Mouse/Rat Behavior Recognition module you can detect rearing behavior 

automatically. 

TRIAL STATISTICS 

Choose Analysis > Results > Statistics and Charts.  

Select other Data profiles and Analysis profiles from the lists on the toolbar to view more 

results. 

GROUP STATISTICS AND CHARTS 

Choose Results > Statistics and Charts, then click the Group Statistics and Charts tab. Select 

the Data profile Groups from the list on the toolbar.  

TIP  Acquire more trials using the two video files and the corresponding detection settings. 

Start tracking at various points in the video to create some variation in the groups. Then open 

the Group Statistics and Charts. 

INTEGRATED VISUALIZATION 

Choose Results > Integrated Visualization, then choose the Data profile and the analysis 

profile from the lists on the toolbar to select the variables you want to plot. 

Choose Distance and velocity from the Analysis profile list on the toolbar.  

Next, on the Track Plot Settings pane click the Colors tab. Under Level choose Sample and 

then Velocity (Center point) as the Variable to visualize. When you play the tracks, you see 

the data points in different colors based on the mouse’s speed. 
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TIP  Click the Jump to end button to view the entire tracks.  

 

HEATMAP VISUALIZATION 

 

Choose Results > Heatmap Visualization. Select the Data profile With time bins from the list 

on the toolbar, then click the Time bins button on the right under Layout presets.  

There you see where the mouse spent time in each of the one-minute time bins. 
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TIP  Click the Fit all button on the toolbar to view all time bins in one row. 

 

ACKNOWLEDGEMENTS 

Video files were kindly provided by Dr. Lior Bikovski, director of the Myers Neuro-Behavioral 
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Elevated plus maze XT190 

OVERVIEW 

This is an example of a plus maze experiment with a mouse. We used nose-tail tracking to 

calculate the mouse’s head dips over the edge of the open arms of the maze.  

Media file 

Elevated plus maze mouse.avi 

ARENA SETTINGS 

Arena Settings 1 

The North and South arms of the maze are open, the other two (West and East) are closed.  

The North and South arms are defined as the cumulative group Open arms in the Arena 

Settings. The West and East arms are defined as the cumulative group Closed arms. We used 

nose-tail tracking to investigate how much time the mouse spent in the open arms. We also 

defined the zones Outside North open arm and Outside South open arm, which together 

form the cumulative zone Outside open arms. We used this cumulative zone to investigate 

how often the mouse showed head dips over the edge of the open arms.  

TRIAL CONTROL SETTINGS 

Trial Control Settings 1 

In the Trial Control Settings we defined a condition to start the track two seconds after the 

mouse was first detected in the arena.  

DETECTION SETTINGS 

Detection Settings 1 

Dynamic subtraction is the detection method used. A maximum body size of 1300 pixels is 

used. This is to prevent EthoVision from tracking the arm of the experimenter who puts the 

animal in the arena. To prevent EthoVision from tracking noise, a minimum body size of 100 

pixels is used. Contour dilation is used to compensate for low contrast in some parts of the 

arena, which makes the rodent’s shape less consistent. 
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TRACK SMOOTHING PROFILES 

The experiment has two Track Smoothing profiles: 

⚫ Smoothing off. Track smoothing is not enabled. 

   

⚫ Filter based on Minimal Distance Moved. A filter based on a minimal distance moved 

from one sample to the next is activated. Keep this profile active especially when 

calculating distance moved, since it filters out false movements caused by noise when the 

mouse is sitting still. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment has three Data profiles: 

⚫ All data. The default Data profile without any filtering or nesting criteria. 

⚫ Results in 30-s bins. This is a Data profile that splits the tracks in 30-s intervals called 

bins. Note that the last bit of the track is excluded from analysis because it is shorter than 

30 s. 

⚫ Results in open/closed arms - With results per zone, and the center point of the mouse 

and the zones open arms and closed arms selected. This divides the tracks into segments in 

which the center point of the mouse is in either the open arms or the closed arms.  

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment has four Analysis profiles: 

⚫ Velocity and distance moved. To calculate the (mean) velocity and (total) distance 

moved of the animal's center-point. 

⚫ Time in open/closed arms. Contains the following variables: 

⚫ In Zone. To calculate the total time spent in open arms and closed arms separately, also as 

percentage of the total recording time. For frequency of arm entries, see the Analysis 

profile Arm entries below. 

⚫ When in open arms > 5 s. This variable is an example of how you can mark events based 

on the duration of a behavior. Here, we want to find the number of times that the animal 

spent more than a specific time, 5 seconds, in either of the open arms.  

To determine the instances of zone visits that last longer than a specific time, a Free 

Interval is used based on the dependent variable In Zone. The start condition is defined 

as the moment the animal’s center-point is in one of the open arms for more  
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than 5 s. The stop condition was defined as the moment the animal’s center-point was 

no longer in the open arm. 

Double-click this variable to see how it was defined. For more information, see Free 

intervals in the EthoVision XT Help. 

When you plot this variable in the Integrated Visualization (Analyze > Results > Plot 

Integrated data), you see that only the visits to the open arms that lasted longer than 5 

second are plotted. 

 

Note that the interval starts five seconds (or the time specified in the start condition of 

the Free Interval Settings) after the animal actually enters the zone.  

⚫ Nose over edge open arms. To calculate the frequency and the duration of head dips over 

the edges of the open arms. To do so, the number of times and the duration the nose point 

was present in the cumulative zone Outside open arms was assessed. 

⚫ Arm entries. This profile contains two Zone transition variables. Entries to Open arms 

counts the transitions from the Center zone to either open arm. Entries to Closed arms 

counts the transitions from the Center zone to either closed arm. Zone transitions are 

generally more reliable indicators of true zone entries than In zone variables, especially 

when the body points jitter around the zone borders. 

⚫ Body Length with JavaScript. This profile contains a custom variable written with 

JavaScript code. You can use JavaScript to extract more information from the track data. In 

this example, the JavaScript code defines the body length as the sum of the distance 

between the nose and the center and between the center and the tail base point of the 

mouse. For more examples of variables with JavaScript, see JavaScript custom variables 

under Drivers and tools/Utilities on the EthoVision XT installation USB stick. 

TRIAL STATISTICS 

Choose Analysis > Results > Statistics and Charts.  

From the lists on the toolbar, choose the Data profile All Data and the Analysis profile Time in 

open/closed arms. With this combination you calculate the time that the subject spent in the 

open arms and in the closed arms. This time is expressed in seconds and in percentage of the 

total time. 
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Combine the Data profile Results in open/closed arms with the Analysis profile Velocity 

and distance moved. There you have the velocity and distance moved in the open and closed 

arms. The subject explored the closed arms far more than open arms. The velocity in the open 

arms was slightly lower than in the closed arms. 

Combine the Data profile All Data with the Analysis profile Arm entries. There you compare 

the number of entries between open arms and closed arms. 

HEATMAPS 

Choose Analysis > Results > Plot Heatmaps. 

Choose the Data profile Results in 30-s bins from the list at the top. Next, click the Time bins 

button on the right-hand pane. You see that the mouse enters the open arms only in the last two 

time bins. This indicates that the mouse needs time to start exploring. 

 

TIP  Click the Fit all button on the toolbar to view all time bins in one row. 

 

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated data. Choose the Analysis Profile and Data 

Profile from the lists on the toolbar. 

Head dipping 

Combine the Data profile All Data and the Analysis profile Nose over edge open arms to 

display the head dips in a time plot.  
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Body length 

Choose the Data profile All data with the Analysis profile Body Length with JavaScript to plot 

the body length against time. There you see an increase in body length at the end of the video, 

each time the mouse enters the open arms. 
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Novel Object Recognition test with Deep  

Learning XT190 

OVERVIEW 

In the Novel Object Recognition (NOR) test, the researcher evaluates the recognition memory 

of the animal. A mouse is presented with two similar objects during the a session 

(Familiarization), and then one of the two objects is replaced by a new object during a following 

session (Test). The amount of time taken to explore the new object provides an index of 

recognition memory. 

In this sample experiment, the software tracks the mouse’s nose to quantify its exploratory 

behavior. Three trials have been acquired: 

⚫ Trial 1 (Habituation). The mouse is free to explore the open field for 5 minutes. 

⚫ Trial 2 (Familiarization). The mouse explores two identical objects, Familiar object 1 and 

Familiar object 2. 

⚫ Trial 3 (Test). The mouse explores one familiar object, the same as Familiar object 2, and 

one novel object, which replaced Familiar object 1. 

NOTE  This experiment uses the Deep learning method for tracking the subject’s nose point. 

This method requires recent CUDA software and a recent graphics card (GPU). These 

requirements may not be met in some computers. In that case, you can visualize the existing 

track but you cannot acquire new data. See the EthoVision XT Help for more information. 

Media files 

⚫ NOR test video no objects.mpg 

⚫ NOR test video two identical objects.mpg. 

⚫ NOR test video familiar and novel object.mpg 

Reference 

Leger et al. (2013). Object recognition test in mice. Nature Protocols 8: 2531–2537. 

EXPERIMENT SETTINGS 

Choose Setup > Experiment Settings. 

To track the subject’s nose, under Tracked Features the option Center-point, nose-point 

and tail-base point detection is selected.  
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Under Body Point Detection Technique you see that EthoVision XT uses Deep learning to 

find the body points of the mouse. 

 

ARENA SETTINGS 

Three Arena Settings are defined: 

⚫ With no objects. Use this profile when tracking from the video file named NOR test video 

no objects.mpg. 

⚫ With identical objects. Use this profile when tracking from the video file NOR test video 

two identical objects.mpg. 

⚫ With novel object. Use this profile when tracking from the video file NOR test video 

familiar and novel object.mpg. 

In the last two Arena Settings profiles, the zone group Objects contains zones covering the 

two objects and boundary zones around each object. The zones are slightly different in the two 

Arena Settings profiles because the objects slightly differ in size and position. 

You can use the boundary zone to define the properties of the dependent variable Head 

directed to zone. 

For all the Arena Settings profiles, two zones Floor and Wall are defined in a separate group 

Floor and Wall which you can use for additional analyses. 

TRIAL CONTROL SETTINGS 

Choose Setup > Trial Control Settings > Open. The experiment contains the profile Start after 

5 seconds. This profile contains a condition to wait five seconds before starting tracking. You 

can use this profile to avoid faulty tracking at the beginning of the video when a change in the 

lighting occurs. 
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DETECTION SETTINGS 

Choose Setup > Detection Settings > Open. The experiment contains three profiles, one for 

each video. The main difference between the three profiles lies in the background image that 

must match the image of the video (without the animal in the arena), with or without the 

objects. Make sure that you use the correct Detection Settings profile when you track from one 

of the three video files. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains three profiles: 

⚫ All Data. This is the default Data profile. 

⚫ Contrast object exploration. This Data profile contains two result boxes. The aim of this 

profile is to compare exploration of the two objects when they are identical versus when 

one of them is novel. The two selections are based on the type of Arena Settings used. 

⚫ Time bins. You can use this profile to analyze exploration per time interval. 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment contains two profiles: 

⚫ Exploration. Here a few variables have been defined to measure exploratory behavior. 

⚫ Nose within object zone measures the time that the subject’s nose touches objects. 

⚫ Distance to objects returns the distance of the subject’s nose to the objects. 

⚫ The variables of type Head directed to [object name] measure the time that the 

subject’s head is directed to the zone, while its center point is in the boundary zone. The 

results are similar to those obtained with Nose within object zone, however this adds the 

condition that the head is directed toward an object, even if the nose is not precisely 

inside the object zone. The measure is expected to quantify the time that the mouse’s 

attention is directed toward the object. 

⚫ Locomotion. In this profile the variables Distance moved and Velocity are defined. 

STATISTICS 

Choose Analysis > Results > Statistics and Charts. 

⚫ From the Data profile on the toolbar, choose All Data and from the Analysis profile list 

choose Exploration. 
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Under Trial Statistics, the results are shown per trial. The table gives you the statistics per 

zone. Note that some zones give result “-” or zero; those results refer to zones that were not 

in the Arena Settings used to acquire that trial. For example, for trial 2, the zones Familiar 

object 1 and Familiar object 2 were used. For trial 3, the zones Familiar object and Novel 

object were used. 

⚫ From the Data profile on the toolbar, choose Contrast object exploration and from the 

Analysis profile list choose Exploration. Choose then Group Statistics and Charts. 

The table shows two groups, one for the Familiarization phase where Familiar object 1 and 

Familiar object 2 are compared, and one for the Test phase where the Novel object replaced 

Familiar object 1.  

In the following example, in the columns under Cumulative Duration, the Familiar object 1 

was explored for about 5 seconds, while the Novel object was explored for about 30  

seconds. The Standard Error is not calculated since only one trial is included per group.
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INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data. 

From the lists on the toolbar, select the Data profile, the Analysis profile and the trial number 

that you want to visualize. 

HEATMAP VISUALIZATION 

Choose Analysis > Results > Plot Heatmaps. 

From the lists on the toolbar, select the Data profile Contrast object exploration. 

Heatmaps give you an immediate sense of where the animal spent most of the time during a 

trial. The following heatmap shows the position of the nose point in Trial 2 (Familiarization; 

left) and Trial 3 (Test; right). In the Test phase, the positions of the nose point are far more 

dense around the novel object than those at the same location during the familiarization phase. 

ACKNOWLEDGEMENTS 

Video files were kindly provided by Dr. Lior Bikovski, director of the Myers Neuro-Behavioral 

Core Facility, Sackler School of Medicine, Tel Aviv University, Tel-Aviv, Israel; and School of 
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 Porsolt forced swim test XT190 

OVERVIEW 

This experiment shows a Porsolt forced swim test performed on two subjects, each being 

tracked in its own arena. Note that you need the Multiple Arenas Module to be able to track 

subjects in two arenas simultaneously. 

Media file 

Porsolt Swim Test.mp4 

ARENA SETTINGS 

In the Arena Settings, an arena has been defined over each of the two water tanks in the video 

image. No zone has been defined as in this experiment the researcher was not interested in 

the exact location of the subject in the tank. 

TRIAL CONTROL SETTINGS 

A Trial Control Settings profile Five minutes track was defined to stop tracking 5 minutes 

after the start of tracking. These settings were used to acquire Trial 1. You can create a 

duplicate of this profile and modify the Time condition to acquire shorter or longer tracks. 

DETECTION SETTINGS 

In the Detection Settings, the Static Subtraction is selected as the detection method. The 

video file was tracked at 12.5 samples per second. Note that the sample rate affects the results 

of Mobility: the higher the sample rate, the smaller are the changes between two consecutive 

video frames, and the lower are the values of per-sample Mobility. For details, see Mobility in 

the EthoVision XT Help. 

TRIAL LIST 

In the Trial List, the variable Session has been defined, with two possible values, Test and  

Pretest. Each trial is assigned to either value. Trial 1, a Test, has been acquired with Animal ID  

1 and 2. Other variables are Treatment, a variable with values Drug and Saline, Animal IDand      
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Dose, a numerical variable with values 0, 2 and 5 mg/l. You can use those variables to filter 

trials and tracks and group subjects. Note that each trial will contain two tracks. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment has two Data profiles. 

⚫ All Data. Contains all data in the experiment. Use this Data profile to visualize statistics 

calculated per trial. 

⚫ Drug vs. Saline. With two groups based on the independent variable Treatment. Use this 

Data profile to compare statistics and charts of the variables per group. 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open.  

Two Analysis profiles include the Mobility dependent variables. Each profile contains two 

variables, Mobility continuous and Mobility state. Mobility continuous returns the value of 

body mobility based on the change in body area between subsequent samples. Mobility states 

marks the behavior of the subjects with one of three possible scores (Immobile, Mobile, Highly 

mobile) based on the value of Mobility relative to user-set thresholds. Doubleclick the name of 

the variable to view those settings. 

⚫ Mobility_1. Mobility is calculated with an Averaging interval of 1, that is, the value is 

obtained directly from the per-sample change in the subject’s apparent body area. However, 

random changes in the body area around the thresholds, due for example to changes in the 

orientation of the animal independent of its swimming behavior, can influence the value of 

Mobility, resulting in many transitions between Mobility scores (e.g. Mobile > Highly mobile 

> Mobile > Highly mobile, etc.). For this reason we also defined a smoothed Mobility variable 

(see below). 

⚫ Mobility_10. The values of Mobility are smoothed out using an Averaging interval larger 

than 1. In this example, the interval is 10 samples wide. The effect of random changes in 

body area is minimized, and that results in fewer transitions between Mobility scores. 

NOTE  For all variables, the following thresholds were used: Immobile below 6.5%, Highly 

mobile above 22%. Feel free to edit those values and open the Integrated Visualization. The 

resulting Mobility scores should match the behavior of the rats in the video as much as 

possible. 
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TRIAL STATISTICS 

Choose Analysis > Results > Statistics & Charts. 

To view the results, select the Data profile and Analysis profile from the list on the toolbar. 

 

GROUP STATISTICS AND CHARTS 

Choose Analysis > Results > Statistics & Charts and open the tab Group Statistics and 

Charts. Select the Data Profile and Analysis Profile from the lists on the toolbar. 

Below you see one of the charts that appear when you select the Data profile Drug vs. Saline 

and the Analysis profile Mobility_10. Click the Mobility state tab just above the charts. 
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Social interaction test in PhenoTyper with  

Deep Learning XT190 

OVERVIEW 

This is an example of how you can analyze the interaction between two or more animals in the 

same arena. Note that you need the Social Interaction add-on module to track two animals 

per arena. 

The two mice in the accompanying video are tracked with the Deep learning method. One of the 

two animals is partially shaved on its back. EthoVision XT uses the difference in visual 

appearance between the two animals to track their identities. Note that this process is 

completed after tracking. For more information, see the topic Prepare the data in multisubject 

trials in the EthoVision XT Help. 

note  This experiment uses the Deep learning method for tracking the subject’s nose point. 

This method requires recent CUDA software and a recent graphics card (GPU). These 

requirements may not be met in some computers. In that case, you can visualize the existing 

track but you cannot acquire new data. See the EthoVision XT Help for more information. 

Media file 

Two mice in PhenoTyper v2.mp4. The footage was recorded with EthoVision XT and a Basler 

digital camera mounted on a PhenoTyper version 2 top unit. 

EXPERIMENT SETTINGS 

In the Experiment Settings, we set the Number of Subjects per Arena to 2; the Tracked 

features to Center-point, nose-point and tail-base detection, and the Body Point 

Detection Technique to Deep learning. The Subject roles are Subject 1 and Subject 2. 

ARENA SETTINGS 

In the Arena Settings, the Zone Group 1 includes two zones (the feeding zone and the area 

covering the top of the shelter) and one point (Drinking spout). 

⚫ To create and edit an Arena Settings profile with the same zones, right-click Arena Settings 

1 and select Duplicate. 

⚫ Alternatively, to create an Arena Settings profile from scratch, using the same video file as 

background image, choose Setup > Arena Settings > New, and load the video file. 
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TRIAL CONTROL SETTINGS 

A Trial Control Settings profile Trial Control Settings 1 has been defined. The condition placed 

before Start track ensures that tracking starts when at least one subject is detected in the cage 

for one second. In this video both animals are present since the start, so tracking starts exactly 

one second from the first video frame. The condition placed immediately before Stop track 

ensures that tracking stops at the end of the video file. 

DETECTION SETTINGS 

When using Deep Learning in two-subjects experiments, the Detection settings under 

Advanced are greatly simplified. In most cases you do not need to adjust the remaining options. 

You are ready to acquire the data! For details about Deep learning-based tracking in EthoVision 

XT, see the EthoVision XT Help. 

TRIAL LIST 

Choose Setup > Trial List.  

Besides other “classic” variable such as mouse strain, treatment level, or age, you may want to 

know which mouse is given the label Subject 1 or Subject 2. This can be useful, for example if 

you want to check whether there are biases in the behavior of animals marked on the back. 

Because of the way the Deep learning method works, which Subject label is given to a marked 

mouse can differ between trials, even when using repeatedly the same video, and cannot be 

established at the start of each trial. 

Click the Add Variable button. In the column that appears: 

⚫ In the Label cell (the first cell of the new column), enter Marked mouse. 

⚫ In the Scope cell select Subject.  

⚫ Double- click the Predefined Values cell in the same column and under Predefined Value 

enter Yes and click Add, next enter No and click Add. 

You can now label each track that you collect based on whether either Subject 1 or Subject 2 

was marked on the back. For each trial acquired, select Yes or No in the corresponding cell of 

the Marked mouse column. Check the tracks in the Integrated Visualization (see below) to 

know which mouse received which label. 

DATA ACQUISITION 

To start tracking, click the Start Trial button. 
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You may note that the software occasionally swaps the identity of the two animals. That’s 

normal during acquisition. 

Once you start analysis, EthoVision XT reviews the tracks and sorts them based on the 

information on the visual appearance of the mice collected during the tracking phase. The 

software re-assigns the labels Subject 1 and Subject 2 to segments of tracks where an 

accidental swap occurred. This phase is called Data Set Preparation. For more details, see the 

EthoVision XT 18 Help. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains the default data profile with 

all data. 

If you have added a variable for the marked animal (see Trial List above), to analyze the 

behaviors of the marked animal, under Filter click the button next to Marked mouse, select 

Yes and insert the box in the sequence between Start and Result 1. 

 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment contains four Analysis profiles. 

⚫ Distance and Velocity, which contains variables typically used to quantify each subject’s 

activity: Distance moved and Velocity.  

⚫ Social behavior measures - S1 and Social behavior measures - S2. These analysis 

profiles are meant to examine the social behavior of Subject 1 and Subject 2. The reason 

why there are separate profiles for Subject 1 and Subject 2 is that they contain JavaScript 

custom variables, each defined for one subject or the other.  

The JavaScript variables analyze the movement and the position of the two subjects and 

output various states of each subject: Approach, Follow (the other subject) and Social 

contact. You can customize the code in the variable settings to fine tune the criteria for 

scoring those behaviors. For example, adjust the speed that define movement, or adjust the 

distance under which we speak of “interaction”. 
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For more examples of JavaScript custom variables, download the JavaScript custom 

variables from my.noldus.com (click downloads, then under EthoVision XT choose 

drivers and tools). 

These analysis profiles also contain typical social behavior variables such as Distance 

between subjects and Proximity. 

⚫ Feeding and Drinking. This profile calculates the frequency, duration and latency of the 

events “nose in feeding zone” and “nose in drinking zone”.  

TRIAL STATISTICS 

Choose Analysis > Results > Statistics & Charts.  

To view the results of the behavior of S1 (Subject 1) towards S2 (Subject 2), locate the row 

Subject 1, then locate the column of a behavior of S1.  

Similarly, to view the variables of the behavior of S2 towards S1, start locating the row Subject 

2 and locate the column of a behavior of S2.  

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot integrated data.  

In the Integrated Visualization screen, you can check how consistent the identity was assigned 

to the two mice. Play the video and view the color of the center point. If identification worked 

correctly, the mouse with a mark on its back should always (or almost always) have the same 

color tag (either green or red). You can correct the remaining identity swaps in the Track 

Editor. 
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Social interaction test in Social Box with  

Deep Learning XT190 

OVERVIEW 

This is an example of how you can analyze the interaction between two or more animals in the 

same arena. Note that you need the Social Interaction add-on module to track two animals 

per arena. 

The two mice in the accompanying video are tracked with the Deep learning method. One of the 

two animals was marked on its tail. EthoVision XT uses the difference in visual appearance 

between the two animals to track their identities. Note that this process is completed after 

tracking. For more information, see the topic Prepare the data in multisubject trials in the 

EthoVision XT Help. 

NOTE This experiment uses the Deep learning method for tracking the subject’s nose point. 

This method requires recent CUDA software and a recent graphics card (GPU). These 

requirements may not be met in some computers. In that case, you can visualize the existing 

track but you cannot acquire new data. See the EthoVision XT Help for more information. 

Media file 

SocialBox_2animals_PORT.avi. 

Video was recorded at the Group of Astrocyte Biology, Łukasiewicz - PORT, Wrocław. Credit: 

Bartosz Zglinicki, Patrycja Ziuzia, Michał S lęzak. 

EXPERIMENT SETTINGS 

In the Experiment Settings, we set the Number of Subjects per Arena to 2; the Tracked 

features to Center-point, nose-point and tail-base detection, and the Body Point 

Detection Technique to Deep learning. The Subject roles are Subject 1 and Subject 2. 

ARENA SETTINGS 

In the Arena Settings, the Zone Group 1 does not contain zones. Add a zone if for example you 

want to know how much time each subject spends in the center of the arena, or near the feeder. 

⚫ To create an Arena Settings profile from scratch, using the same video file as background 

image, choose Setup > Arena Settings > New, and load the video file. 
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TRIAL CONTROL SETTINGS 

A Trial Control Settings profile Trial Control Settings 1 has been defined. The condition placed 

before Start track ensures that tracking starts when at least one subject is detected in the cage 

for one second. In this video both animals are present since the start, so tracking starts exactly 

one second from the first video frame. The condition placed immediately before Stop track 

ensures that tracking stops at the end of the video file. 

DETECTION SETTINGS 

When using Deep Learning in two-subjects experiments, the Detection settings under 

Advanced are greatly simplified. In most cases you do not need to adjust the remaining options. 

You are ready to acquire the data! For details about Deep learning-based tracking in EthoVision 

XT, see the EthoVision XT Help. 

TRIAL LIST 

Choose Setup > Trial List.  

Besides other “classic” variable such as mouse strain, treatment level, or age, you may want to 

know which mouse is given the label Subject 1 or Subject 2. This can be useful, for example if 

you want to check whether there are biases in the behavior of the animals marked on their tail. 

Because of the way the Deep learning method works, which Subject label is given to a marked 

mouse can differ between trials, even when using repeatedly the same video, and cannot be 

established at the start of each trial. 

Click the Add Variable button. In the column that appears: 

⚫ In the Label cell (the first cell of the new column), enter Marked mouse. 

⚫ In the Scope cell select Subject. 

⚫ Double- click the Predefined Values cell in the same column and under Predefined Value 

enter Yes and click Add, next enter No and click Add. 

You can now label each track that you collect based on whether either Subject 1 or Subject 2 

was marked on its tail. For each trial acquired, select Yes or No in the corresponding cell of the 

Marked mouse column. Check the tracks in the Integrated Visualization (see below) to know 

which mouse received which label. Next, fill in the cells under Marked mouse in the  

Trial List. 
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DATA ACQUISITION 

To start tracking, click the Start Trial button. 

You may note that the software occasionally swaps the identity of the two animals. That’s 

normal during acquisition. 

Once you start analysis, EthoVision XT reviews the tracks and sorts them based on the 

information on the visual appearance of the mice collected during the tracking phase. The 

software re-assigns the labels Subject 1 and Subject 2 to segments of tracks where an 

accidental swap occurred. This phase is called Data Set Preparation. For more details, see the 

EthoVision XT 18 Help. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains the default data profile with 

all data. 

If you have added a variable for the marked animal (see Trial List above), to analyze the 

behaviors of the marked animal, under Filter click the button next to Marked mouse, select 

Yes and insert the box in the sequence between Start and Result 1. 

 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment contains four Analysis profiles. 

⚫ Distance and Velocity, which contains variables typically used to quantify each subject’s 

activity: Distance moved and Velocity. 

⚫ Social Behavior. These analysis profiles are meant to examine the social behavior of  

Subject 1 and Subject 2. They contain typical output variables like Train, Side by side, and 

Proximity, but also an example of JavaScript custom variables, each defined for one subject 

or the other.  

The JavaScript variable analyzes the movement and the position of the two subjects and is 

scored when one subject approaches the other. You can customize the code in the  
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variable settings to fine tune the criteria for scoring that behavior. For example, adjust the 

speed that define movement, or adjust the distance under which we speak of 

“approaching”. 

For more examples of JavaScript custom variables, download the JavaScript custom 

variables from my.noldus.com (click downloads, then under EthoVision XT choose 

drivers and tools). 

TRIAL STATISTICS 

Choose Analysis > Results > Statistics & Charts.  

To view the results of the behavior of Subject 1 towards Subject 2, locate the row Subject 1, 

then locate the column of a behavior that starts with Subject 1.  

Similarly, to view the variables of the behavior of Subject 2 towards Subject 1, locate first the 

row Subject 2 and locate the column of a behavior that starts with Subject 2.  

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot integrated data.  

In the Integrated Visualization screen, you can check how consistent the identity was assigned 

to the two mice. Play the video and view the color of the center point. If identification worked 

correctly, the mouse with a mark on its tail should always (or almost always) have the same 

color tag (either green or red). You can correct the remaining identity swaps in the Track 

Editor. 
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Social Interaction test with color markers  

XT190 

OVERVIEW 

This is an example of how you can analyze the interaction between two or more animals in the 

same arena. Note that you need the Social Interaction add-on module to track more than one 

animal per arena. 

Media file 

Social Interaction test.mp4. 

EXPERIMENT SETTINGS 

In the Experiment Settings, we set the Number of Subjects per Arena to 2 and the Tracked 

features to Center-point, nose-point and tail-base detection. The Subject roles are 

Control and Treated. 

ARENA SETTINGS 

In the Arena Settings, the Quadrants zone group includes four quadrants to be able to 

analyze the location of the subject during the test. 

⚫ To create a new Arena Settings profile with pre-defined arena and zones, right-click Arena 

Settings 1 and select Duplicate. 

⚫ Alternatively, to create an Arena Settings profile from scratch, using the same video file as 

background image, choose Setup > Arena Settings > New, and load the video file. Make 

sure to adjust the video aspect ratio. To do so, click the Adjust Aspect Ratio button at the 

bottom of the Arena Settings window. 

 

In the window that appears, choose Custom and enter 768 and 576 as video image size.  

This adjusts the video image size to the original proportions. 
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TRIAL CONTROL SETTINGS 

A Trial Control Settings profile One-minute track has been defined. Tracking starts when both 

subjects are detected in the cage for two seconds. With this Trial Control profile you ensure that 

the subjects are tracked for exactly the same time. The other condition placed immediately 

before “Stop track” ensures that tracking stops after one minute. 

DETECTION SETTINGS 

In the Detection settings, we selected Dynamic subtraction with Marker-assisted 

identification. 

When you select Center-point, nose-point and tail-base detection in the Experiment 

settings for multiple animals, EthoVision XT automatically selects the Rodents/For 

occlusions as nose-tail tracking method. 

Because the animals frequently come in close contact, in the advanced Subject Size settings, 

the Modelling effort optimized for slider is moved to Modelling and the Shape stability 

optimized for slider is moved to Occlusions. For details about those options, see Advanced 

detection settings: Subject size (multiple animals per arena) in the EthoVision XT Help. 

TRIAL LIST 

Choose Setup > Trial List. User-defined variables Dose, Day and Marker color are defined. 

You can use the Marker color variable to specify Subject role * Marker color combinations. In 

the acquired trial, the Treated subject has a yellow marker. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains the default data profile with 

all data. 

To analyze the behaviors of the animals in the four quadrants separately, click the Settings 

button on the Results box, select Results per zone and select the four quadrants. Then redo 

the analysis. 

 

 

 

 



 

  Social Interaction test with color markers XT190  33 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment contains two Analysis profiles. 

The first is Individual behavior, which contains variables typically used to quantify each 

subject’s activity: distance moved, velocity and the state variable Movement (Moving vs Not 

Moving).  

The second profile is Social behavior with the following dependent variables: 

⚫ Distance nose point to tail base Control. This calculates the mean distance from the 

nose-point of both animals to the tail-base of the Control animal. 

In the statistics table, look up the value for the Treated animal, to obtain the distance from 

the nose point of the treated animal to the tail base of the control animal. 

⚫ Proximity nose point to tail base Control. This calculates the mean duration of the states 

In proximity and Not in proximity based on the distance from the nose-point of both 

animals to the tail-base of the Control animal. The states In proximity and Not in proximity 

have with a lower and upper threshold of 5 and 6 cm, respectively. 

In the statistics table, look up the value for the Treated animal, to see whether the nose 

point of the treated animal is in proximity to the tail base of the control animal.  

⚫ Distance nose point to tail base of Treated. This calculates the mean distance from the 

nose-point of both animals to the tail-base of the Treated animal. 

In the statistics table, look up the value for the Control animal, to obtain the distance from 

the nose point of the control animal to the tail base of the treated animal.  

⚫ Proximity nose point to tail base of Treated. This calculates the mean duration of the 

states In proximity and Not in proximity based on the distance from the nose-point of 

both animals to the tail-base of the Treated animal. The states In proximity and Not in 

proximity have with a lower and upper threshold of 5 and 6 cm, respectively. 

In the statistics table, look up the value for the Control animal, to see whether the nose 

point of the control animal is in proximity to the tail base of the treated animal.  

⚫ Body Contact. This calculates whether the animals are in contact with each other or not. 
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TRIAL STATISTICS 

Choose Analysis > Results > Statistics & Charts.  

For variables of distance and proximity of the rat Treated to the rat Control, locate the column 

Distance (Proximity) nose point to tail base of Control, then locate the row for Treated. 

For example, the average distance of the nose point of Treated to the tail base of Control was 

about 29 cm. 

 

Similarly, for the variables of distance and proximity of Control to Treated, locate the column 

Distance (Proximity) nose point to tail base of Treated and locate the row for Control. The 

average distance of the nose of Control to the tail-base of Treated was about 24 cm. 

 

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot integrated data.  

The figure below shows an example of the variable In proximity based on the nose-point of 

Treated and the tail-base of Control. 



 

  Social Interaction test with color markers XT190  35 

 

Please note that the plots for the subject Control displaying Distance/Proximity of nose point 

to the tail base of Control, that is, the distance between body points of the same animal, do not 

contain useful information. The same holds for the plots of the subject Treated displaying 

Distance/Proximity nose point to the tail base of Treated. 

The next figure shows the plot of the variable Body contact. Body contact is scored when the 

animals were in physical contact with any part of their bodies, not just their nose points or tail 

bases. 
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Social approach test with Deep Learning  

XT190 

OVERVIEW 

This sample experiment uses a method based on trained neural networks, also known as Deep 

learning, to track the nose of the test subject. In the Social approach test, the subject is free to 

explore an apparatus divided in three compartments (Left, Center, Right). A conspecific is 

placed under a wire cage in one of the sides of the apparatus (either Left or Right; social zone), 

while an empty wire cage (control zone) is placed at the opposite side. The aim of the test is to 

measure the “Sociability”, that is the propensity to spend time with another subject, as 

compared to time spent alone in an identical but empty chamber. 

 

⚫ The videos include the image of two arenas, so you need the Multiple Arena module to do 

tracking in both arenas simultaneously. If you do not have the Multiple Arena Module, you 

can create Arena Settings with one arena and track from that arena. 

⚫ In order to acquire data with this experiment, you need a graphics card (GPU, or secondary 

graphics card) which supports a recent version of CUDA software. Make sure that the 

driver for that card is up to date. 

Media files 

⚫ Social approach test Trial 1.mp4: The social zone is in the left compartment. 

⚫ Social approach test Trial 2.mp4: The social zone is in the right compartment. 
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EXPERIMENT SETTINGS 

In the Experiment Settings, we set the Number of Arenas to 2 and the Number of Subjects 

per Arena to 1 because we are going to track only one subject, that is, the test subject, not the 

subject under the wire cage. 

Under Tracked Features, Center-point, nose-point and tail-base detection is selected. The 

Body Point Detection Technique is set to Deep learning.  

note  If the driver of the GPU is not compatible with the CUDA version needed to use Deep 

learning, a message appears next to this option. You can only visualize the data already acquired 

(Trials 1 and 2). Another option is to install this experiment on a PC with a more recent graphics 

card. For more information, see the topic Deep learning: Requirements in the EthoVision XT 

Help. 

ARENA SETTINGS 

Two Arena Settings are defined, one for each video file, depending on in which compartment 

they placed the wire cage with the second mouse (left or right).  

⚫ Social zone left. Use this profile when tracking from the video file Social approach test 

Trial 1.mp4, where the social zone is in the left compartment. 

⚫ Social zone right. Use this profile when tracking from the video file Social approach test 

Trial 2.mp4, where the social zone is in the right compartment. 

In both Arena Settings, and for both arenas, each wire cage is defined as a zone (either Social 

zone or Control zone, depending on whether they contain a mouse). Furthermore, a larger zone 

(Outer social zone and Outer control zone), is defined for analysis purposes (see below).  

Note that the arena does not include the part of the image where the mouse inside the wire 

cage is visible. This has been done to avoid that the software tracks that mouse. 

Before you start tracking, make sure that you choose the correct Arena Settings for that video! 

TRIAL CONTROL SETTINGS 

In the beginning of the video, the operator removes the doors that divide the compartments in 

both arenas. That marks the start of the test. The Trial Control Settings includes a condition 

“Wait 6 seconds after detecting the mouse”. This has been done to ensure that tracking starts 

after the arms of the operator are no longer visible in the video. 
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DETECTION SETTINGS 

The method Dynamic subtraction has been used to detect the contour of the test mouse. Deep 

learning is used to find the nose-point and the tail-base point.  

In case you create new Detection Settings, under Method click Define and make sure that the 

yellow square box includes the entire body of the mouse in Arena 2. 

 

DATA PROFILES 

The experiment includes two Data profiles: 

⚫ All data. Use this data profile for an OVERVIEW of all tracks. 

⚫ Groups KO vs WT. Two fictitious groups, WT and KO, have been created, each containing 

two tracks. You can view which track belongs to which group in the Type column of the 

Trial List. Use this data profile to compare groups of test subjects. 

ANALYSIS PROFILES 

The experiment includes three Analysis profiles: 

⚫ Time spent in compartments. This profile includes a variable of type In zone to quantify 

the time that the mouse spent in the three compartments (Left, Center and Right). It is 

based on the detection of the mouse’s center point in each zone. 

⚫ Exploration of social vs control zones. This profile is based on the detection of the nose 

point and the head direction, and aims at quantifying exploration more in detail.  

⚫ A variable of type In zone tells when the nose of the mouse is within the social zone and 

the control zone. The variable is smoothed out using a Zone exit threshold. 

⚫ Two variables of type Head directed to zone, one for the social zone and the other for the 

control zone, measure the time that the animal’s head was directed to a zone 

(social/control) while its body center was in the outer zone (Outer social/control  
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zone). This extra condition acts as a filter to exclude the instances when the animal was 

pointing to the zones of interest but was still far from them. 

⚫ Locomotory activity. This profile includes Distance moved and Velocity, to quantify the 

level of activity of the mouse. 

TRIAL STATISTICS 

Choose Analysis > Results > Statistics and Charts. Choose a Data profile and an Analysis 

profile from the toolbar to visualize the results. 

GROUP STATISTICS 

Choose Analysis > Results > Statistics and Charts then click Group Statistics and Charts. 

Select the Data profile Groups KO vs WT to view the statistics for two groups of tracks.  

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data. 
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HEATMAPS 

Choose Analysis > Results > Plot Heatmaps. Select the Data profile Groups KO vs WT and 

click Adjacent in the panel on the right. The heatmaps are based on the nose point, so you see 

exactly where exploration was directed to. 
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PhenoTyper hardware XT190 

OVERVIEW 

This is an example of how you can use Trial Control to carry out a conditioning experiment in a 

PhenoTyper cage.  

The aim of this experiment is to teach a mouse to go from the pellet feeder on top of the shelter 

to receive a reward (a food pellet). The start of the conditioning session (“pellet session”) is 

indicated by a yellow light cue from the PhenoTyper top unit (see also trial control settings). 

In the video file, video recordings of two PhenoTyper cages have been combined. The top row 

shows Arena 1, the bottom row Arena 2. The videos on the left are the recordings with a 

normal camera, which enable you to see the yellow light come on at the start of the ‘pellet 

session’. The videos on the right show the recordings of the PhenoTyper top unit IR-camera. 

This view is used for video-tracking. 

 

Media file 

PhenoTyper hardware.mp4. Note that although the video shows two lickometers placed near 

the PhenoTypers, lickometer data are not included in this experiment. 
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EXPERIMENT SETTINGS 

The Video Source was originally set to Live tracking to acquire data, record video and control 

the PhenoTyper devices. It was then set to From video file to allow acquisition of new trials 

from the existing video file. Under Trial Control Hardware, Use of Trial Control hardware is 

selected. 

ARENA SETTINGS 

In the Arena Settings, two arenas have been defined, Arena 1 (top-right) and Arena 2 (bottom-

right). 

Four zone groups have been defined: 

⚫ PhenoTyperFloor. Includes the zone PhenoTyperFloor. 

Use this zone to calculate, for instance, distance moved in a 

horizontal plane (so, excluding vertical movement of the 

mouse climbing on the shelter). 

⚫ OnShelter. Includes the zone OnShelter, to calculate the time spent on top of the shelter. 

⚫ PelletZone. Includes the zone PelletZone. This zone is used to trigger the hardware action 

Drop Pellet (see trial control settings below) when the animal moves from this zone on 

top of the shelter. 

⚫ Shelter (hidden zone group). This is a special group of zone, named Hidden zone group. It 

includes a hidden zone named Shelter and its entry zone named Entry Zone 1. A hidden 

zone, together with its entry zone (or zones), allows to calculate the time spent inside the 

shelter. For more information on hidden zones, see the EthoVision XT Help. 

Under Arena - Hardware mapping, a PhenoTyper top unit and a Pellet dispenser have been 

assigned to each arena. 

If you wish to create a new Arena Settings profile, after selecting the video file as a background 

image adjust the Aspect ratio (728x576).  

DETECTION SETTINGS 

To detect the mice, the method named Dynamic Subtraction was used to compensate for the 

temporal changes in the background, caused primarily by the movement of the bedding material 

during the test. 
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TRIAL CONTROL SETTINGS 

In the Trial Control Settings, the following procedure has been programmed. To view the 

details of actions and conditions, click the Settings buttons within the Trial Control boxes. 

1. After a set time of 30 seconds (box A), tracking starts, at which moment the yellow light of 

the PhenoTyper top unit is turned on (box B) as a signal that a ‘Pellet session’ starts. A 

pellet is dropped that marks the start of the task (“Start Pellet”; box C). Next, the  

Reference ‘Start Pellet Session’ (box D) is activated. This starts the sub-rule ‘Pellet Session’ 

(box E). This sub-rule is repeated 3 times, according to what is specified in the Reference 

box. 

2. In the sub-rule ‘Pellet Session’, every time the animal moved from PelletZone to the 

OnShelter zone (box F), a pellet is dropped (box G). 

3. When this has occurred 3 times, or when 5 minutes have passed since the start of the track 

(box H), the yellow light in the top unit is switched off (box I) and tracking stops. 

  

 

DATA ACQUISITION 

Choose Acquisition > Open Acquisition. Ignore the message There is no IO-box connected 

and click Continue. You can acquire a new trial using the same video file PhenoTyper 

hardware.mp4. To start acquisition, click the Start Trial button. 

DATA PROFILES 
Choose Analysis > Data Profile > Open. The sample project contains the following Data 

profiles: 
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⚫ All data. The default Data profile that selects all tracks in the experiment.  

⚫ All data - Results per zone. When this Data profile is active, the dependent variables are 

calculated for each selected zone separately. 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The sample project contains the following 

analysis profiles: 

⚫ In and On shelter and in pellet zone. This profile contains the variables Inside shelter, 

On shelter and In pellet zone. With these variables you can calculate the frequency and 

duration of the time spent in each zone and also the latency of entering each zone. The 

fourth variable, Drop pellet, is a variable of type Hardware command. With this variable 

you can visualize and calculate the number of pellets dropped by the Pellet dispenser (see 

also the figure under integrated visualization). 

⚫ Total distance moved and mean velocity. This profile contains the variables Distance 

moved and Velocity. With this Data profile the mean distance moved and mean velocity is 

calculated.  

⚫ Time to complete the task. Consider the following variables: 

⚫ From first to third Drop Pellet. This is a Trial Control state based on the events “Drop 

pellet” in the subrule. You can use it for example to visualize and calculate the time from the 

first and the third Drop pellet event. 

⚫ Time to complete the task. Unlike the variable above, this is a free interval, which starts 

from the first event “Start Pellet” to the last “Drop Pellet” of the Pellet session (subrule). It is 

a measure of the time to complete the task. 

ANALYSIS 

Choose Analysis > Results > Statistics and Charts. Select the Analysis profile In and On 

shelter and in pellet zone and the Data profile All data. Locate the columns: 

⚫ Inside shelter. Here you find how often and how long the mice were in the shelter.  

⚫ Drop pellet. Here you can see how many commands “Drop a pellet” have been given for 

each subject. 

⚫ On Shelter. Under Latency to Last, you find the time that the subject reached the top of the 

shelter for the last time. This is a measure of the time taken to complete the task. you can 

see that it took the animal in Arena 1 119.6 s to get its last reward, whereas the  
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animal in Arena 2 needed 86.9 s. Hence, the animal in Arena 1 was slower than the animal 

in Arena 2 at getting the three rewards.  

⚫ In pellet zone. Locate this column in the analysis results table, and note the difference 

between the subjects in Arena 1 and Arena 2 in the time spent in the pellet zone. 

Now select the Analysis profile Total distance moved and mean velocity from the toolbar.  

The results table shows the total distance moved and the mean velocity of the two mice. When 

you select the Data profile Results per Zone from the toolbar, the table is updated and shows 

the total distance moved and the velocity in each of the zones. 

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data. Choose the Data Profile and Analysis 

Profile from the lists on the toolbar. The visualization of Analysis profile In and On shelter 

and in pellet zone is shown in the next picture. 
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At the bottom-right corner of the screen the Trial Control Events panel shows you when the 

trial control events took place, for example when a condition became true or a pellet drop was 

performed. 

If you do not see this list, at the top-right corner click Show/Hide and select Trial Control 

Events. 

Double-click any row in the Trial Control Events panel. The events (conditions and actions) 

that are active at that time are highlighted in red. 

 

ACKNOWLEDGEMENT 
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DanioVision with 96 wells XT190 

OVERVIEW 

This is an example of an experiment carried out with a DanioVision system. In this experiment, 

96 zebrafish larvae were tracked in a well-plate. One minute after the start of tracking, using 

trial and hardware control, a light stimulus was turned on for 1 minute. After this minute, the 

light was turned off again for 1 minute and then tracking stopped. During live acquisition, the 

Trial Control protocol White Light Routine (see page 49) ensures that the stimuli are given at 

the right time. You can then compare several behavioral endpoints between the three phases of 

the trial (between light; during light; after light). To assess very rapid movements of the larvae, 

a camera frame rate of 60 frames per second (fps) was used. 

Media file 

DanioVision 96 wells.avi 

EXPERIMENT SETTINGS 

In the original experiment, the Video Source was Live tracking and Use of Trial Control 

hardware was selected. The experiment was then set to track From video file so you can 

acquire your trials from the video file, using your own Arena, Trial Control and Detection 

settings. 

NOTE  If you open Acquisition, a message appears saying that EthoVision XT cannot find the 

DanioVision connected. Click Continue to go on with data acquisition. 

TRIAL LIST 

At the top-right corner, click Show/Hide and select Variables. Choose to view: 

⚫ Treatment was created as a user-defined variable with the predefined values Treated and 

Control.  

⚫ Subject not found and Missed samples. These are system variables. Subject not found is 

almost always 0% for Trial 1, which means that the subject was always found in each well, 

and for each frame of the video. The Missed samples is always 0%, which indicates that no 

sample was skipped. 
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ARENA SETTINGS 

Ninety-six arenas were created for the well-plates. In the Arena - Hardware Mapping 

window, the DanioVision White Light was specified. 

NOTE  Creating a zebrafish experiment is facilitated by the automatic detection of the wells. 

See the DanioVision DVOC-0041 - Reference Manual.pdf for details. 

TRIAL CONTROL SETTINGS 

This sample experiment contains two Trial Control settings: 

⚫ Default. This is the default Start-Stop trial control rule. You can use this to acquire data 

without controlling the DanioVision White Light. 

⚫ White Light Routine. This was used for acquiring Trial 1. The following procedure was 

programmed:  

⚫ After a time of 1 minute (Condition box “Time (1)”, see A in the figure below), a 

Reference (see the Reference box, B) activated the sub-rule White light routine (Rule 

Begin box, see C).  

⚫ In this sub-rule, the white light was turned on to 100% of its maximum intensity in 5 

seconds (Action box “White Light On”, see D) and was on for 1 minute (Condition box 

“Time (2)”, see E).  

⚫ Next, the white light was turned off from 100% to 0% in 1 second (Action box “White 

Light Off”, F). 

⚫ After a time of 1 minute (Condition box “Time (3)”, G) tracking was stopped (Action box 

“Stop track” H). 

 

TIP  Click the Settings buttons to see the details of a Trial Control box. 
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DETECTION SETTINGS 

The DanioVision method was used. A sample rate of 60 samples per second was used. 

DATA ACQUISITION 

Choose Acquisition > Open Acquisition. Ignore the message There is no IO-box connected 

and click Continue. You can acquire a new trial using the video DanioVision 96 wells.avi. To 

start acquisition, click the Start Trial button. 

TRACK SMOOTHING PROFILES 

Choose Acquisition > Track Smoothing Profiles > Open.  

A track smoothing profile MDM 0.2 mm has been defined in which a Minimal Distance  

Moved (MDM) filter is used. This filter removes sample-to sample distances shorter than 0.2 

mm. For the DanioVision set-up a Minimal Distance Moved filter of 0.2 mm is recommended for 

a good estimate of distance moved (swim path length). For details, see the DanioVision DVOC-

0041 - Reference Manual.  

If you want to analyze data without this filter, choose Acquisition > Track Smoothing Profile 

> New. In the new profile Track Smoothing Profile 1, all filters are disabled. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The project contains the following Data profiles:  

⚫ All data, Treated vs. Control. Contains entire tracks, but split in two groups based on the 

value of the Treatment independent variable, Treated or Control. 

⚫ Intervals based on White Light state. This contains three separate Result boxes are 

defined. Using the Nesting function Trial Control State, the tracks are split in three 

intervals (each represented by a Result box):  

– 1. Before White light goes on. This interval goes from the start of the track to the 

moment that the White Light On command was activated (box D in the figure). 

– 2. White light on. This interval goes from when the command “White Light On” was 

activated (box D in the figure) to when “White Light Off” was activated (box F). 

– 3. After white light goes off. This interval goes from when “White Light Off” was 

activated (box F) to the stop of the track (box H).  

In this Data profile, Treated and Control subjects are analyzed together. 
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⚫ Before vs. after White light on. This is an example of how you can use the Free Interval 

function to select a segment of the tracks depending on a combination of time and events. 

With this Data profile you compare the two seconds immediately before the white light 

goes on and the two seconds immediately after it goes on. The Data profile also splits the 

data further based on control vs. treated subjects. 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The project contains the following analysis 

profiles:  

⚫ Distance moved and Velocity. With the mean and total Distance moved and the mean 

Velocity.  

⚫ Movement. In this Analysis profile, the frequency, duration and latency of the behavioral 

state Movement are calculated for each subject, which is a measure of their locomotor 

activity. Use the Data profile Intervals based on White Light state to see in which time 

period the light was on (see the figure under integrated visualization below). 

⚫ Rotation. The variable CW Rotation counts the number of clockwise rotations, and CCW 

Rotation calculates the number of counter-clockwise rotations. 

⚫ Turn angle. To quantify the amount of turning (in degrees) per sample.  

INTEGRATED VISUALIZATION 

IMPORTANT  Visualizing the video and analysis results for 96 subjects is very processor 

intensive. Close all other software running on your computer before taking this step.  

Choose Analysis > Results > Plot Integrated Data. Choose the Data Profile, Analysis Profile 

and Result from the lists on the toolbar.  

The figure below shows the tracks and the variables when you select: 

⚫ The Data profile Intervals based on white light state. 

⚫ The Analysis profile Movement. 

⚫ The Result 1. Before White Light goes on. 

Yellow and red tracks are of Treated and Control subjects, respectively.  

Choose another item from the third list to view the results for another interval. Note that the 

third list is only available if your Data profile contains two or more Result boxes. 
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STATISTICS 

Choose Analysis > Results > Statistics & Charts.  

When you open the Group Statistics & Charts tab and select the Data profile Interval based 

on white light state and the Analysis profile Distance moved and Velocity, the table shows 

the statistics of distance moved and velocity for each interval 1. Before white light on, 2. White 

Light on, and 3. After white light off. The decrease in distance moved (swim path length) and 

velocity in the interval 2. White Light on suggests that the white light reduced the activity levels 

of the larvae. A similar result can be seen when you select the Data profile Before vs. after 

White light goes on. 

Furthermore: 

⚫ Select the Data profile Intervals based on white light state and the Analysis profile  

Rotation or Movement. There you see that rotation and frequency of movement  
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significantly decreased after turning on the white light, and strongly increased after turning 

it off again. 

⚫ Select the Data profile All data, Treated vs. Control and the Analysis profile Rotation or 

Turn Angle. You see some difference between Treated and Control subjects in the average 

values of rotation (clockwise and counterclockwise) and turn angle, although this 

difference is probably not statistically significant. 

ACKNOWLEDGEMENT 

M. ter Veld (The Aquaculture and Fisheries Group, Animal Sciences Group, Wageningen UR, 

The Netherlands) is gratefully acknowledged for supplying us with zebrafish larvae. 

FOR MORE INFORMATION 

See the DanioVision DVOC-0041 - Reference Manual.pdf. You can find this manual in All Apps > 

Noldus > EthoVision XT 19 Other Documentation. 
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DanioVision with camera zoomed into 

four wells XT190 

OVERVIEW 

This is an example of an experiment carried out with a DanioVision system using a camera 

with a zoom lens. The image of a 96 well plate was zoomed in to four wells.  

In this experiment, four zebrafish larvae (two controls, two treated) were tracked for about ten 

minutes. The aim of the experiment was to compare activity and movement parameters 

(including rotation frequency) in the two experimental groups.  

Media file 

DanioVision four wells.avi 

EXPERIMENT SETTINGS 

The Video Source was set to From video file. Because the four wells are independent 

replicates, the number of Arenas was set to 4 and the number of Subjects per Arena was 1. 

TRIAL LIST 

Choose Setup > Trial List. A user defined variable Treatment is defined with the predefined 

values Treated and Control. Each subject is assigned either value.  

ARENA SETTINGS 

Four arenas were created for the well-plates. Each arena was divided into a border zone and a 

center zone. 

TIP  In EthoVision XT, creating a zebrafish experiment is facilitated by pre-defined templates in 

which settings, including arena settings, have already been made to enable you to set up an 

experiment more quickly. Also, adjusting arenas is easy with the Multiple Arena Setup.  

See the EthoVision XT Help for details. 
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TRIAL CONTROL SETTINGS 

In the Trial Control Settings profile named Default, tracking was set to start as soon as the trial 

was started, that is, when one clicks the Start trial button. Tracking lasts until the end of the 

video file. 

DETECTION SETTINGS 

In the Detection Settings named Detection Settings 1, the DanioVision method was selected. 

To remove some noise the subjects’ contour was filtered using the options under Subject 

Contour: Erosion (1 pixel) followed by Dilation (1 pixel). 

TRACK SMOOTHING PROFILES 

Under Track Smoothing Profiles, besides a profile named No Smoothing with no smoothing 

selected, a second profile, MDM 0.2 mm is defined (MDM = Minimal Distance Moved). When 

you use this track smoothing profile, data points with a distance from the previous point of less 

than 0.2 mm are set to the previous position. This removes a large part of the false movements 

of the subject’s center point which do not correspond to actual movement of the fish. We 

recommend using this filter for the DanioVision set-up.  

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment has the following Data profiles: 

⚫ All Data. The default Data profile with all the data. 

⚫ Treated vs. Control vs. All data, with time bins. To compare treated and control animals 

in 1-minute intervals.  

⚫ Treated vs. Control vs. All data, no time bins. To compare treated and control animals 

throughout the whole test duration. 

For both Treated vs. Control Data profiles, the Result box All data allows you to view the 

results when pooling the data of the two treatment levels. 
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ANALYSIS PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains four Analysis profiles: 

⚫ Distance, Time & Movement. In this Analysis profile, the total Distance Moved and the 

mean Velocity are calculated. Also, the frequency, duration, percentage of time spent and 

latency of the behavioral state Movement are calculated for each zebrafish larvae, which is 

a measure for their activity.  

⚫ Path shape. In this Analysis profile, the path shape of the larvae is determined by 

calculation of the mean relative Turn Angle and the mean relative Angular Velocity.  

⚫ Rotation. In this Analysis profile, the variable CW Rotation counts the number of clockwise 

rotations, CCW Rotation calculates the number of counter-clockwise rotations.  

⚫ In zone - In this Analysis profile, the time until the first visit and the frequency, duration 

and percentage of time spent are calculated for the center zone and border zone.  

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated data. 

On the toolbar you can choose which of the treatments to display (Treatment, Control or All 

data). You can also choose other Analysis profiles, Data profiles or track smoothing profiles 

from the lists on the toolbar. 

The next figure shows the visualization of the Analysis profile Rotation. The animal in Arena 1 

(top left in the video) has just completed a counter-clock wise (CCW) rotation. This is marked 

with the vertical segment in the first plot, CCW Rotation.  

Tracks of Control and Treated subjects are visualized in different colors. To change colors, click 

the Colors tab on the right-hand panel.  
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ANALYSIS 

Choose Analysis > Results > Statistics & Charts, then click the Grouped Statistics and 

Charts tab. Select the Data profile and the Analysis profile you want to use from the toolbar. 

For example, select the Data profile Treated vs. Control vs. All data no time bins, and the 

Analysis profile Rotation. The counts of rotations are shown for the two treatment groups 

separately and for all the trials together. 
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Barnes Maze test with Deep Learning 

XT190 

OVERVIEW 

This sample experiment shows you how you can use the dependent variable Target visits and 

errors, to analyze the animal’s path in a memory test paradigm where certain zones are defined 

as targets. For more information, see the EthoVision XT Help. 

In a Barnes maze experiment, a mouse or rat tends to escape from the brightly lit surface of the 

maze. One of the holes gives entrance to an escape box, which is a dark shelter under the hole 

board. The animal is trained to find the escape box. During this training phase, the number of 

visits to other holes should decrease rapidly, which is a measure for learning ability. In the 

probe phase, the escape box is removed. The time to reach the hole where the escape box 

previously was is determined, together with the number of visits to other holes and the total 

distance moved.  

In this example, three white mice were tracked during training trials. EthoVision XT uses neural 

networks to find the nose and the tail base of the subjects. In this experiment you will see that 

the nose point is found correctly even when part of the body of the subject is not detected as the 

mouse walks near the white patches. 

Media files 

⚫ Trial 1.mpg 

⚫ Trial 2.mpg ⚫ Trial 3.mpg 

EXPERIMENT SETTINGS 

⚫ The Video Source was set to From video file.  

⚫ As Tracked Features, Center-point, Nose-point, and Tail-base detection is selected. 

⚫ Under Body Point Detection Technique, Deep learning is selected. 

NOTE  In order to use Deep learning, your PC must have a compatible graphics card (GPU) 

and its drivers must be up-to-date. Consul the EthoVision XT Help and contact Noldus to 

purchase a compatible graphics card. 
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ARENA SETTINGS 

Since the position of the holes is slightly different in the three videos, the project contains 

separate arena settings for each video. Each arena settings contains: 

⚫ A zone group called Holes, with zones H1 to H18. These are zones that cover the holes. H1 

to H17 are non-target holes. H18 is the zone of the escape box. The zone H18 is used for 

analysis of the time that the nose point was inside the zone, just like for H1 to H17. 

⚫ Non-target holes. This is a cumulative zone with the zones H1 to H17. You can use this 

zone to calculate and visualize the total time spent exploring all non-target holes. 

⚫ A hidden zone group with the zone Target hole. This is a hidden zone that covers the hole 

with the escape box. It covers the same area as zone H18, but it is used during acquisition. 

When the mouse enters the entry zone, and then disappears, EthoVision XT considers it to 

be in the hidden zone and stops the trial. The entry zone is a ring around the target hole. 

See the EthoVision XT Help for more information about hidden zones. 

TRIAL CONTROL SETTINGS 

The experiment contains trial control settings Max. track duration 3 min. The track starts when 

the mouse was detected in the arena for two seconds. It ends either after three minutes, or 

when the mouse has been in the hidden zone Target hole for one second.  

DETECTION SETTINGS 

Under Advanced, Dynamic Subtraction is used with the appropriate contrast (Subject color 

Brighter than background) to detect a mouse with white fur. Tn the Deep learning settings, 

the bounding box should include some space between the mouse and its edges. For example:  

 

TRIAL LIST 

The trial list contains the following user-defined variables: 
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⚫ Treatment. This variable indicates which experimental group the mouse belongs to. It has 

the predefined values Treated and Control. 

⚫ Animal ID. This numerical variable identifies the mice, for example 1, 2, 3, etc. 

⚫ Type of Trial. This variable indicates the type of trials and has the predefined values 

Training and Probe. 

TRACK SMOOTHING PROFILES 

The experiment contains two profiles: 

⚫ No smoothing applied. Select this profile to view the unfiltered data points.  

⚫ Lowess smoothing On. With this profile, the data points are filtered using the Lowess 

method (recommended; for details. see the EthoVision XT Help). 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The project contains two Data profiles.  

⚫ All data. This is the default Data profile that contains all tracks. 

⚫ Treated vs. Control. The trials are grouped, based on the independent variable 

Treatment. Two groups are created: 

⚫ Treated, with one trial.  

⚫ Control, with two trials. 

ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The project contains two analysis profiles.  

⚫ Distance & Velocity. with the total distance moved and the mean velocity. 

⚫ Hole visits. This profile contains two variables. 

⚫ Target visits and errors. Double-click this variable to see how it is set up.  

Under Target zones, the Target hole is selected.  

Under Non-target zones, the holes H1 to H17 are selected (note: do not select Other 

holes together. You can use this zone in the variable Hole exploration time; see 

below). 

On the Body points tab, Nose-point is selected, that is, a visit is calculated when the 

nose point is detected within the corresponding zone. 
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With this variable you can calculate (1) the number of visits to the targets (including 

revisits), (2) the number of visits to non-target holes, (3) the latency to the first visit to 

the target holes. In probe trials, revisits to target holes and all visits to non-target holes 

are considered as errors. 

Note that this variable also includes a Zone exit threshold. That means that, when the 

nose-point is just outside one of the hole zones, but within the threshold distance, the 

nose-point is still considered in the zone. Therefore, the zone visit only ends when the 

nose-point is found further than the threshold distance. You can use the Zone exit 

threshold to avoid that multiple nose pokes are considered as separate visits. 

⚫ Hole exploration time. This is an instance of the dependent variable In zone. You can 

use this variable to calculate the total time that the animal’s nose was detected inside 

each hole, or all holes together. For this purpose, the cumulative zone Other holes 

together is also selected in the variable’s settings (see under In the following zones). 

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data.  

On the toolbar you can choose which of the trial types to display (Treated vs. Control or All 

data). You can also choose Analysis profiles, or Track Smoothing profiles from the lists on the 

toolbar. The first plot shows the target visits and errors. The second plot shows the hole 

exploration time. 

TRIAL STATISTICS 

Choose Analysis > Results > Statistics & Charts. Select the Data profile and the Analysis 

profile you want to use from the toolbar. 

For example, when selecting the Data profile Treated vs. Control and the Analysis profile 

Hole visits, you can compare the number of errors made by treated and control mice. 

When you select the analysis profile Distance & Velocity, you can compare the distance 

moved and the speed of the subjects. 
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Mouse Behavior Recognition in Open Field  

XT190 

OVERVIEW 

The aim of this sample experiment is to demonstrate how EthoVision XT automatically detects 

various behaviors of mice, like rearing, walking and sniffing. 

Media file 

Mouse Behavior Recognition in Open Field.mpg. 

Note 

To work with the Behavior Recognition function, you need the Mouse Behavior Recognition 

Module. For information about performance and the limitations of the Behavior Recognition 

function, see Behavior Recognition in the EthoVision XT Help. See also the paper by van Dam 

et al. (2013). An automated system for the recognition of various specific rat behaviours. Journal 

of Neuroscience Methods 218,(2), 214–224. 

EXPERIMENT SETTINGS 

Under Analysis Options, Behavior Recognition is selected. The options are selected that 

apply to the video, thus Arena walls is selected, not Feeder and Drinking bottle, which are 

not present in the cage. For the same reason, the additional options available when clicking 

Settings are not selected. 

ARENA SETTINGS 

In the Arena Settings, two zone groups are defined:  

⚫ Zone Group 1, with two zones, Center and Border. 

⚫ Wall Zones, with a zone called Wall Zone 1. This zone is important for automatic detection 

of rearing. It is defined by drawing a polyline shape around the open field floor, excluding 

the Plexiglas blocks at two of the corners. Note that the zone label is placed outside the 

shape, and points to the walls. 
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DETECTION SETTINGS 

A Detection Settings profile has been defined: 

⚫ Under Video, the Sample rate is set to 29.97, the maximum for that video. Behavior 

Recognition works with a sample rate of 25 samples/s or higher. 

⚫ Under Advanced, Contour erosion/dilation is set to the minimum. If you create your own 

detection settings, we advise you not to increase contour erosion/dilation as this might 

affect recognition of subtle behaviors, like sniffing. 

⚫ Behavior settings are set under Behavior Recognition. If you create your own settings, 

click the Define Subject Properties button, play the video up to when the animal walks 

with a normal posture and average speed, and click Grab.  
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For details, see Detection Settings for Behavior Recognition in the EthoVision XT Help.  

TRIAL CONTROL SETTINGS 

The settings in Trial Control Settings 1 specify that EthoVision XT waits three seconds after 

the mouse has been detected in the arena, before it starts actual tracking. This is because the 

Behavior Recognition function needs a few seconds of data before being able to detect 

behaviors.  

 

Without the additional Time condition, the first three seconds of the track would not be 

scored. 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains three Data profiles. 

⚫ All data. The default Data profile without any filtering or nesting criteria. Use this profile to 

analyze and visualize the whole data set. 

⚫ When rearing, When sniffing. These two Data profiles select the track segments in which  

Rearing (supported or unsupported) and Sniffing were detected, respectively. Use these Data 

profiles to produce heatmaps. The resulting heatmap shows where that behavior occurred. 

HEATMAPS 

Choose Analysis > Results > Plot Heatmaps. Select the Data profile When grooming or 

When sniffing. The heatmap indicates where that behavior took place.  
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ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment contains two Analysis profiles. 

⚫ Behaviors and probability. Specifies all ten behaviors that can be detected. Behaviors are 

analyzed with the default settings. The last item in the list is Behavior probability of the 

various behaviors. Note that the behavior scored at a certain time is the one with the 

highest probability. You can modify the Analysis profile in such a way that a behavior is only 

scored when its probability exceeds a specific value, for example 90%. 

⚫ Rearing (merged). This is an example of how you can analyze two behaviors as one.  

Rearing supported and Rearing unsupported are merged in one behavior, renamed  

Rearing (merged). The Behavior probability of the two Rearing behaviors is also specified. 

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data. 

⚫ Select the Analysis profile Behaviors and probability. There you can see the instances of 

the behaviors detected.  
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The plot at the bottom of the screen shows the probability of the behaviors. 

 

TIP  Use Behavior probability to check whether some instances of behavior have low 

probability. To remove those instances, in the Analysis profile double-click that behavior 

and under Behavior decision method specify Probability greater than. 

⚫ Select the Analysis profile Rearing (merged behaviors) to see how different behaviors are 

merged in one category. 
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Mouse Behavior Recognition in Social  

Discrimination XT190 

OVERVIEW 

The aim of this sample experiment is to demonstrate how EthoVision XT can automatically 

detect various behaviors of a mouse, like sniffing, digging and grooming.  

Media file 

Mouse Behavior Recognition in Social Discrimination.mp4. 

Note 

To work with the Behavior Recognition function, you need the Mouse Behavior Recognition 

Module. For information about performance and the limitations of the Behavior Recognition 

function, see Behavior Recognition in the EthoVision XT Help. See also the paper by van Dam 

et al. (2013). An automated system for the recognition of various specific rat behaviours. Journal 

of Neuroscience Methods 218,(2), 214–224. 

EXPERIMENT SETTINGS 

Although the video shows two mice in the same cage, only one was tracked. Therefore, under 

Number of Subjects, 1 is selected. 

Under Analysis Options, Behavior Recognition is selected. The options are selected that apply 

to the video, thus Arena walls is selected, not Feeder and Drinking bottle which are not 

present in the cage. When clicking the Settings button, the additional option Bedding present 

is selected. 

ARENA SETTINGS 

The test cage has been divided in three compartments: a central compartment where the focal 

male mouse is confined, and two side compartments. In the right compartment a female mouse 

is placed to serve as a social stimulus.  

In the Arena Settings, only the central compartment of the home cage has been defined as 

Arena, because that is where the focal subject is going to be moving. The other subject, 

confined in the right compartment, is not tracked.  
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A zone group Wall Zones is defined. It contains one zone called Wall Zone 1. This zone is 

important for automatic detection of rearing. It is defined by drawing a polyline shape around 

the open field floor. Note that the zone label is placed outside the shape, and points to the 

walls.  

 

A zone group is also defined with two zones, Social side (right) and Non-social side (left). This 

way you can split your results based on the position of the nose point in one of the two zones. 

For example, to calculate the total duration of Sniffing when the mouse’s nose was in the zone 

“Social”. 

 

NOTE  If you have a similar experiment/apparatus and you want to exchange the social with the 

non-social sides, by placing the social mouse in the left compartment, you do not need to re-

create the arena and zones. First, duplicate the Arena settings. Then, in the new Arena Settings, 

swap the labels of the two zones. Use the new Arena Settings for the trials when the social mouse 

is placed in the left compartment. 
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DETECTION SETTINGS 

A Detection Settings profile has been defined: 

⚫ Under Video, the Sample rate is set to 25, the maximum for that video. This is compulsory 

for behavior recognition. 

⚫ Under Advanced, both Contour erosion and Contour dilation are set to 2. If you create 

your own detection settings, we advise you not to increase contour erosion/dilation as this 

might affect recognition of subtle behaviors, like sniffing. 

⚫ Under Behavior Recognition, you find the settings for the subject size and posture. If you 

create your own settings, click the Define Subject Properties button, play the video up to 

when the animal walks with a normal posture (e.g. 3:06.760), and click Grab. 

 

For details, see Detection Settings for Behavior Recognition in the EthoVision XT Help.  

TRIAL CONTROL SETTINGS 

The settings in Trial Control Settings 1 specify that EthoVision XT waits three seconds after 

the mouse has been detected in the arena, before it starts actual tracking. This is because the 

Behavior Recognition function needs a few seconds of data before being able to detect 

behaviors. Without the additional Time condition, the first three seconds of the track would 

not be scored. 
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ACQUISITION 

During data acquisition, you can view live statistics of events and behaviors of the subjects. In 

the Acquisition screen, after starting a trial, click the Dependent Variables tab. There you can 

view how many times and for how long the mouse’s nose was detected in the zone Social side 

(highlighted on the video window). To view more dependent variables, at the topright corner of 

the screen click Show/Hide > Show Dependent Variable. 

 

DATA PROFILES 

Choose Analysis > Data Profile > Open. The experiment contains three Data profiles. 

⚫ All data. The default Data profile without any filtering or nesting criteria. Use this profile to 

analyze and visualize the whole data set. 

⚫ When sniffing, When digging. These two Data profiles select the track segments in which 

Sniffing and Digging were detected, respectively. Use these Data profiles to produce 

heatmaps. The resulting heatmap shows where that behavior occurred. The Data profile 

When sniffing is further divided into two result boxes, one for each side of the cage. This 

means that you can analyze sniffing when the nose point was in one of the sides, Social vs. 

Non social. 
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ANALYSIS PROFILES 

Choose Analysis > Analysis Profile > Open. The experiment contains three Analysis profiles. 

⚫ Behaviors and probability. Specifies the behaviors that can be detected automatically. 

Behaviors are analyzed with the default settings (that is, using the criteria of the behavior 

recognition algorithm). In this sample experiment we focus on behaviors like Digging, 

Grooming and Sniffing. Behavior probability is defined for those behaviors but you can 

also select it for others. This gives you an idea of the level of confidence that EthoVision XT 

has when scoring a particular instance of one of those behaviors. Doubleclick this item and 

specify to view the probability of the remaining behaviors. The last item in the list is for 

when no behavior was scored; usually this is at the end of the video; to check this, see 

integrated visualization. 

⚫ Sniffing. This is an example of how you can filter instances of a behavior based on their 

probability and duration. It contains the same behavior, Sniffing, evaluated with two 

criteria: default and with probability higher than 75%. The second means that Sniffing is 

scored if the probability of Sniffing is higher than 75%. You can set the threshold 

probability in the variable settings, under Behavior Decision Method. The second filter is 

specified under Behavior Duration Threshold. There you specify to include the instances 

of Sniffing longer than a certain threshold (here 0.20 s). The third variable in this profile is 

the probability of Sniffing calculated for each sample. 

⚫ Sitting still with nose in social zone. This is an example of a Multi condition variable. It 

combines two dependent variables, In zone (Nose point in social zone) and Movement (Not 

moving). The thresholds for Moving and Not moving are 4.00 and 3.75 cm/s respectively. 

The analysis profile also contains the dependent variable Velocity of center point. If you plot 

the dependent variables in an integrated visualization, you can use the values of Velocity to 

fine tune the settings for Movement.  

HEATMAPS 

Choose Analysis > Results > Plot Heatmaps. Select the Data profile When sniffing. Since that 

profile only selects the samples when the animal was scored as Sniffing, the heatmap indicates 

where sniffing took place. 
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INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data. 

⚫ Select the Analysis profile Behaviors and probability. There you can see the instances of 

the behaviors detected. The plot Behavior probability shows how the probability of a 

behavior changes with time. See the definition of probability in the analysis profiles. 

TIP  Use this chart to check whether some instances of behavior have low probability (= 

high uncertainty). To remove those instances, in the Analysis profile double-click that 

behavior and under Behavior decision method specify Probability greater than. 

⚫ Select the Data profile All data and the Analysis profile Sniffing to see the effect of filtering 

instances of Sniffing based on probability.  

⚫ Select the Data profile All data and the Analysis profile Sitting still with nose in social 

zone to see when the animal was exploring the social zone without moving.  
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Rat Behavior Recognition in PhenoTyper  

XT190 

OVERVIEW 

The aim of this sample experiment is to demonstrate how EthoVision XT can automatically 

detect various behaviors of a rat, like rearing, grooming, sniffing, drinking and eating, in a 

home-cage environment. 

Media file 

Rat Behavior Recognition in PhenoTyper.mpg. 

Note 

To work with the Behavior Recognition function, you need the Rat Behavior Recognition 

Module. For information about performance and the limitations of the Behavior Recognition 

function, see Behavior Recognition in the EthoVision XT Help. See also the paper by van Dam 

et al. (2013). An automated system for the recognition of various specific rat behaviours. Journal 

of Neuroscience Methods 218,(2), 214–224. 

EXPERIMENT SETTINGS 

Under Analysis Options, Behavior Recognition is selected. All options for Rat Behavior 

Recognition are selected: Feeder, Drinking bottle and Arena walls. 

ARENA SETTINGS 

In the Arena Settings, four zone groups are defined:  

⚫ Zone Group 1, with no zones defined. You can use this layer to define for example the 

Center and Border zones of PhenoTyper. 

⚫ Drinking Spout Points. Because PhenoTyper for rats has two drinking bottles, two 

drinking spout points are defined for detection of drinking, Spout 1 and Spout 2. 
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⚫ Feeder Zones. Includes one zone, Feeder Zone 1 for detecting feeding behavior. 
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⚫ Wall Zones. It includes one zone, Wall Zone 1. This zone is important for automatic 

detection of rearing at the walls. It is defined by drawing a polyline shape around the 

PhenoTyper’s floor. Note that the zone label is placed outside the shape, and points to the 

walls. 

 

DETECTION SETTINGS 

A Detection Settings profile has been defined: 

⚫ Under Video, the Sample rate is set to 25, the maximum for that video. This is compulsory 

for behavior recognition. 

⚫ Behavior settings are set under Behavior Recognition. If you create your own settings, 

click the Define Subject Properties button, play the video up to when the animal walks 

with a normal posture, and click Grab. 
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⚫ Under Advanced, Contour erosion/dilation is set to the minimum. If you create your own 

detection settings, we advise you not to increase contour erosion/dilation as this might 

affect recognition of subtle behaviors, like sniffing. 

For details, see Detection Settings for Behavior Recognition in the EthoVision XT Help.  

TRIAL CONTROL SETTINGS 

The settings in Trial Control Settings 1 specify that EthoVision XT waits three seconds after 

the rat has been detected in the arena, before it starts actual tracking. This is because the 

Behavior Recognition function needs a few seconds of data before being able to detect 

behaviors. Without the additional Time condition, the first three seconds of the track would 

not be scored. 

 

DATA PROFILES 

Choose Analysis > Data profile > Open. The experiment contains two Data profiles. 

⚫ All data. The default Data profile without any filtering or nesting criteria. Use this profile 

to analyze and visualize the whole data set. 

⚫ When sniffing. This Data profile selects the track segments in which Sniffing was detected 

for more than half second (click the Settings button in the Nest box to view the settings). 

With this profile activated, you can create a heatmap to show where Sniffing occurred. 

TIP  Choose Analysis > Data Profile > New and create a similar Data profile for when the 

rat was grooming or rearing. 
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ANALYSIS PROFILES 

Choose Analysis > Analysis profile > Open. The experiment contains two Analysis profiles: 

⚫ Behaviors and probability. This Analysis profile contains all ten behaviors that can be 

detected, plus their probability (last item in the list). Some behaviors are analyzed with the 

default settings (that is, using the criteria of the behavior recognition algorithm), others 

with more restrictive criteria, for example when the behavior instance is longer than a 

certain time, or its probability is higher than 90%. Modify those settings and see what 

changes in the behavior visualization. 

TIP  Click the item Merged behavior in the list of variables under Behavior Recognition 

and analyze two or more behavioral categories as one. 

⚫ Distance and Velocity. This profile contains two dependent variables, Distance moved and 

Velocity to quantify the overall activity of the subject. 

INTEGRATED VISUALIZATION 

Choose Analysis > Results > Plot Integrated Data. 

Select the Analysis profile Behaviors and probability. There you can see the instances of the 

behaviors detected. The plot at the bottom shows the probability of the single behaviors.  
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TIP  Use the time plot to check whether some instances of a behavior have low probability. You 

can specify to have the software ignore those instances as they contain some uncertainty of 

classification. To do so, in the Analysis profile double-click that behavior and under Behavior 

decision method specify Probability greater than and enter your threshold value (e.g. 

90%). 

HEATMAPS 

Choose Analysis > Results > Plot Heatmaps. Select the Data profile When sniffing. The 

heatmap indicate where that behavior took place.  
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Shoaling behavior with JavaScript XT190 

OVERVIEW 

This sample experiment provides an example of the capabilities of JavaScript code embedded 

in EthoVision XT, which you can use to further analyze your raw data. In this sample 

experiment a group of five zebrafish is tracked and the researcher wants to count how many 

fish are in each quadrant at any time, and quantify the time that all the fish swim together. For 

this, JavaScript code processes the raw data (position of each fish) and calculates the output 

variables (see Analysis profiles below). 

Video file 

Zebrafish shoal 5 fish.mp4 

experiment settings 

The experiment is set to offline tracking. Under Video Source, the option From video file is 

selected. 

The center point of each fish is tracked, therefore under Tracked Features, the option 

Centerpoint detection is selected. 

ARENA SETTINGS 

The arena has been divided in four quadrants, named Zone 1 to Zone 4. 

DETECTION SETTINGS 

The method Dynamic Subtraction is used for body detection. The fish are not individually 

marked, so under Subject Identification the option Unmarked subjects is selected. 

DATA PROFILES 

⚫ All subjects. This is the default Data profile containing all tracks.  

⚫ One subject selected. This profile only contains the data for the subject labeled Subject 1. 

Since the statistics of subject counts are applied to each subjects, and therefore generate  
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 Shoaling behavior with JavaScript XT190 

redundant results (for example, the mean number of subjects in zone 1 is 1.58 for Subject 1, 

1.58 for Subject 2, 1.58 for Subject 3 etc.), this profile makes the results table simpler. 

Therefore, when you want to visualize the statistics of the number of subjects in the various 

zones, activate this Data profile. 

ANALYSIS PROFILES 

Besides the default Analysis profile with distance and velocity, four profiles have been created. 

⚫ Distance and velocity. Use this profile to calculate the total Distance moved and the 

average speed of each fish. 

⚫ JS Continuous - Interindividual Distance. This profile contains one JavaScript continuous 

variable that calculates the average distance of each subject from all the others. Results are 

shown per subject. 

⚫ JS Continuous - Number of subjects in 4 quadrants. This profile contains four JavaScript 

continuous variables. Here “continuous” means that the number of subjects in each zone is 

updated at each sample. 

⚫ JS Continuous - Subject coordinates. This is another example of the use of JavaScript 

code. The variables contain the x, y coordinates of the subject, respectively. Using JavaScript 

functions and commands you can create additional variables which process that data. 

⚫ JS States - All fish in one quadrant. The variables in this profiles are state variables, 

meaning that the value can be 0 of 1. Use state variables to calculate the time that the fish 

are all in a particular zone, or any zone, or the latency of the first occurrence of the event 

“all fish in a zone”. 

⚫ JS Continuous - Ratio of Subjects. This is another example of how you can extract 

additional information from data like “subject in zone”. A JavaScript variable calculates the 

ratio of the number of subjects swimming in Zone 1 to the total number of subjects. 

Because this is a JavaScript continuous variable, the ratio is updated at each sample. 

⚫ JS Continuous - Nearest Neighbor Distance. This profile contains two variables: (a) 

Distance between subjects, which outputs the distance of each fish from each of its mates, 

at every sample; and (b) JavaScript Continuous - NND, a JavaScript continuous variable 

that calculates the shortest distance from each subject to all the others, and for each 

sample.  
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INTEGRATED VISUALIZATION 

Choose Results > Plot Integrated Data. 

Select from the list on the toolbar: Data profile One subject selected and Analysis profile JS 

Continuous - Number of subjects in 4 quadrants. The plots show the number of fish in Zone 

1, Zone 2, etc. against time. 

 

Now select from the list on the toolbar: Data profile All subjects and Analysis profile JS 

Continuous - Nearest Neighbor Distance. For each subject, one plot, Distance between 

subjects (mm), shows the distance of that fish from each of the other fish, plotted against 

time. The other plot, JavaScript Continuous - NND, shows the Nearest Neighbor Distance of 

that subject plotted against time. You can see that the value of JavaScript Continuous - NND at 

any time is always equal to the lowest value among those plotted in Distance between 

subjects. 
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